Bug 82440 - Handle non-US keymaps that need US keymaps loaded as well
Handle non-US keymaps that need US keymaps loaded as well
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-keyboard (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-22 00:15 EST by Brent Fox
Modified: 2008-05-01 11:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:29:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brent Fox 2003-01-22 00:15:23 EST
// If you want non-latin layouts implicitly include the en_US layout
See bug #80141 for more information.

 // uncomment lines below
-//! $nonlatin = am ar ben bg by dev el ge_la ge_ru guj gur il il_phonetic\
-//              ir iu mk mm ru sr th tj tml ua
+! $nonlatin = am ar ben bg by dev el ge_la ge_ru guj gur il il_phonetic\
+              ir iu mk mm ru sr th tj tml ua

 ! $pcmodels = pc101 pc102 pc104 pc105
 ! $mac = macintosh macintosh_old

This list is actually a list of layouts that use non-latin1 characters
and with new model they must always be loaded together with "us" layout. So,
anaconda must know this list and configure keyboards from this list together
with us keyboard ("us,ru") and configure switch between us and non-us layout
(see keyboard configuration in WinXP installer, for example).
Comment 1 Brent Fox 2003-01-22 00:18:37 EST
This applies for anaconda too.  It will require changes to the
keyboard_models.py in rhpl.
Comment 2 Brent Fox 2003-01-22 00:23:28 EST
msf, katzj: just so you know, I'll have to make this change to
keyboard_models.py.  I'll try not to break anything that the installer uses, but
we'll need to test it.

I think putting a nested list of the required X keymaps inside the
self.modelDict will work pretty well.  For example, the line:

'ru'      : [_('Russian'), 'ru', 'pc105', ''],

will look like:

'ru'      : [_('Russian'), ['ru', 'us'], 'pc105', ''],

That way, we can write an XF86Config file that looks like:
Option      "XkbLayout"    "us,ru"
Comment 3 Brent Fox 2003-01-22 09:57:14 EST
So, of that list, we only have entries for bg, el, mk, ru, and ua in
keyboard_models.py.  I have not added the other keymaps to this list because I'm
not sure of which console keymaps that they use.  

I had to add a column to self.modelDict in keyboard_models.py to specify the
XkbOptions field for these keyboards, which is "grp:ctrl_shift_toggle"

So now the line for ru looks like:

'ru' : [_('Russian'), 'ru,us', 'pc105', '', 'grp:ctrl_shift_toggle' ],
Comment 4 Brent Fox 2003-01-22 10:31:07 EST
rhpl-0.79-1 and redhat-config-keyboard-1.0.3-1 should fix this issue.
Comment 5 Aleksey Nogin 2003-01-23 15:23:36 EST
What about upgrades? Will they result in broken X configuration? I understand
the difficulties with trying to auto-fix an existing config, but it might be a
good idea to at least mention it in release notes - along the lines "If you are
upgrading from a previous version of Red Hat and you have your XWindow Sytem
configured to use an international keyboard layout, you will need to re-generate
your configuration (use redhat-config-keyboard or redhat-coonfig-xfree86) ."
Comment 6 Mike A. Harris 2003-01-23 23:45:47 EST
I agree it should be in release notes.  I disagree however with bfox that
it should be handled by XFree86.

Having some type of "upgrade XFree86 from release A to release B" script
might be useful, but cramming it into XFree86.spec is a recipe for
unmaintainable disaster.  I'm not sure what the best solution is, just
that I don't have the time resources to implement it.
Comment 7 Leonid Kanter 2003-02-07 09:44:36 EST
see comments https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=79287#c21 and
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=79287#c22.
redhat-config-keyboard is OK, please fix anaconda.
Comment 8 Brent Fox 2003-05-25 10:29:18 EDT
There is a stack of 64 bugs that have been in Modified state for a long period
of time.  I am closing these as Rawhide now.  If you find that the issue is not
fixed, please reopen this report.

Note You need to log in before you can comment on or make changes to this bug.