Bug 824402 - snmptrapd core dumps while running within valgrind with perl trap handler
Summary: snmptrapd core dumps while running within valgrind with perl trap handler
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: net-snmp
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Jan Safranek
QA Contact: Dalibor Pospíšil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-23 12:07 UTC by Dalibor Pospíšil
Modified: 2013-02-21 10:27 UTC (History)
0 users

Fixed In Version: net-snmp-5.5-44.el6
Doc Type: Bug Fix
Doc Text:
Previously, snmptrapd daemon destroyed embedded perl interpreter immediately when TERM signal was received, regardless if the embedded perl was still used or not. This could lead to rare crashes of the daemon during shutdown. In this update, the embedded perl interpreter is destroyed later during the daemon shutdown, when all perl processing is already finished.
Clone Of:
Environment:
Last Closed: 2013-02-21 10:27:09 UTC
Target Upstream Version:


Attachments (Terms of Use)
valgrind log (150.71 KB, application/octet-stream)
2012-05-23 12:07 UTC, Dalibor Pospíšil
no flags Details
patch (856 bytes, patch)
2012-05-23 12:18 UTC, Jan Safranek
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0421 normal SHIPPED_LIVE net-snmp bug fix and enhancement update 2013-02-20 20:49:35 UTC

Description Dalibor Pospíšil 2012-05-23 12:07:56 UTC
Created attachment 586321 [details]
valgrind log

Description of problem:
snmptrapd core dumps while running within valgrind with perl trap handler.

# cat /etc/snmp/snmptrapd.conf
disableAuthorization yes
perl do "/usr/local/bin/trapreciver.pl";

# cat /usr/local/bin/trapreciver.pl
#!/usr/bin/perl
use SNMP;
sub my_receiver {
print "Trap received\n";
}
NetSNMP::TrapReceiver::register("all", \&my_receiver)
    or warn "Failed to register Perl trap handler\n";
print "Registered Perl trap handler\n";


Version-Release number of selected component (if applicable):
net-snmp-5.5-41.el6
valgrind >= 3.6.0-5.el6

How reproducible:
always


Steps to Reproduce:
1. # valgrind -v --leak-check=yes /usr/sbin/snmptrapd -Lsd -p /var/run/snmptrapd.pid -f &
2. send trap: # service restart snmpd
3. kill %1
  
Actual results:
snmptrapd core dumps

Expected results:
no core dump

Additional info:

Comment 1 Jan Safranek 2012-05-23 12:16:07 UTC
snmptrapd destroys embeded perl in TERM signal handler. After snmptrapd handles the signal, it returns to processing of incoming traps and if embedded perl is enabled, it may call it. But the embedded perl is already destroyed -> SIGSEGV.

This bug is reproducible only with valgrind-3.6.0-5.el6, older -4.el6 release does not exhibit this bug.

Comment 2 Jan Safranek 2012-05-23 12:18:40 UTC
Created attachment 586326 [details]
patch

Comment 3 Jan Safranek 2012-05-23 12:22:10 UTC
(In reply to comment #0)
> How reproducible:
> always

I would say it's reproducible in about 30% of test runs on my virtual machine, definitely not 100%.

Comment 4 RHEL Product and Program Management 2012-09-10 08:19:36 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 9 errata-xmlrpc 2013-02-21 10:27:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0421.html


Note You need to log in before you can comment on or make changes to this bug.