Bug 824412 - Installation fails for missing velocity-tools package
Installation fails for missing velocity-tools package
Status: CLOSED NOTABUG
Product: Spacewalk
Classification: Community
Component: Installation (Show other bugs)
1.7
x86_64 Other
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Pazdziora
Red Hat Satellite QA List
:
Depends On:
Blocks: space18
  Show dependency treegraph
 
Reported: 2012-05-23 08:25 EDT by Steve Berg
Modified: 2012-11-01 12:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-25 15:29:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full output from "yum install spacewalk-postgresql" (14.05 KB, text/plain)
2012-05-23 08:25 EDT, Steve Berg
no flags Details

  None (edit)
Description Steve Berg 2012-05-23 08:25:20 EDT
Created attachment 586331 [details]
Full output from "yum install spacewalk-postgresql"

Description of problem:
Installation on new install of Scientific Linux 6.2 fails because no velocity-tools package can be found.

Version-Release number of selected component (if applicable):
1.7

How reproducible:
Everytime

Steps to Reproduce:
1. Follow RHEL 6 installation instructions on spacewalk wiki.
2. Configure and verify repos are set up.
3. Install postgresql and verify it's operational.
4. Run yum install spacewalk-postgresql 

  
Actual results (full output in attachment):
From the end of the yum process:
--> Running transaction check
---> Package sitemesh.noarch 0:2.4.1-1.jpp5 will be installed
--> Processing Dependency: velocity-tools for package: sitemesh-2.4.1-1.jpp5.noarch
---> Package spacewalk-slf4j.noarch 0:1.6.1-1.el6 will be installed
--> Finished Dependency Resolution
Error: Package: sitemesh-2.4.1-1.jpp5.noarch (jpackage-generic)
           Requires: velocity-tools
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
Spacewalk-postgresql should install cleanly finding all required packages.

Additional info:
[root@valdez ~]# yum repolist
Loaded plugins: fastestmirror, kmdl, priorities, protectbase, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * epel: mirror.hiwaay.net
 * rpmforge: mirror.us.leaseweb.net
 * sl: ftp2.scientificlinux.org
 * sl-security: ftp2.scientificlinux.org
282 packages excluded due to repository priority protections
0 packages excluded due to repository protections
repo id                     repo name                                                 status
adobe-linux-i386            Adobe Systems Incorporated                                       17
adobe-linux-x86_64          Adobe Systems Incorporated                                        2
atrpms                      Red Hat Enterprise Linux 6 - x86_64 - ATrpms                  2,009
epel                        Extra Packages for Enterprise Linux 6 - x86_64             7,305+40
jpackage-generic            JPackage generic                                          2,641+666
rpmforge                    RHEL 6.2 - RPMforge.net - dag                               4,326+1
sl                          Scientific Linux 6.2 - x86_64                             6,114+225
sl-security                 Scientific Linux 6.2 - x86_64 - security updates             501+16
spacewalk                   Spacewalk                                                       135
repolist: 23,050


[root@sw-server ~]# yum list velocity*
Loaded plugins: fastestmirror, kmdl, priorities, protectbase, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * epel: mirror.hiwaay.net
 * rpmforge: mirror.us.leaseweb.net
 * sl: ftp2.scientificlinux.org
 * sl-security: ftp2.scientificlinux.org
282 packages excluded due to repository priority protections
0 packages excluded due to repository protections
Installed Packages
velocity.noarch                       1.4-10.7.el6               @/velocity-1.4-10.7.el6.noarch
Available Packages
velocity-demo.noarch                  1.4-10.7.el6               sl                            
velocity-javadoc.noarch               1.4-10.7.el6               sl                            
velocity-manual.noarch                1.4-10.7.el6               sl
Comment 1 Jan Pazdziora 2012-05-23 11:38:48 EDT
Your jpackage generic repo configuration or priorities are wrong.

I just did

# cat > /etc/yum.repos.d/jpackage-generic.repo << EOF
> [jpackage-generic]
> name=JPackage generic
> #baseurl=http://mirrors.dotsrc.org/pub/jpackage/5.0/generic/free/
> mirrorlist=http://www.jpackage.org/mirrorlist.php?dist=generic&type=free&release=5.0
> enabled=1
> gpgcheck=1
> gpgkey=http://www.jpackage.org/jpackage.asc
> EOF

# yum install velocity-tools
[...]
================================================================================
 Package                  Arch   Version                 Repository        Size
================================================================================
Installing:
 velocity-tools           noarch 1.4-1.jpp5              jpackage-generic 145 k
Installing for dependencies:
[...]

Also, checking

http://www.jpackage.org/mirrorlist.php?dist=generic&type=free&release=5.0

and using the first URL

http://ftp.heanet.ie/pub/jpackage/5.0/generic/free

I can see

http://ftp.heanet.ie/pub/jpackage/5.0/generic/free/RPMS/velocity-tools-1.4-1.jpp5.noarch.rpm

under it just fine.

Please investigate why your yum does not get that rpm.
Comment 2 Steve Berg 2012-05-24 08:28:42 EDT
I think it may have been caused by my local configs.  I mirror the SL repos, Fedora 15 & 16, along with rpmfusion,rpmforge, epel, atrpms locally to save on bandwidth.  All my systems then use a local repo for updates.  I tested another install on Fedora 15, not using my local repos and the spacewalk installed with no errors.  I'm not installing on SL6.2, using the normal repos instead of my local repos and it's working.  

My local repos are sync'd using reposync, then I run createrepo on them to get them ready for clients.  Could I be missing something in that process that would cause the repo to appear different somehow?
Comment 3 Jan Pazdziora 2012-05-25 15:29:36 EDT
Throwing as many repos as possible on the problem isn't always the best option. I don't think the repos are quaranteed to work all together.

Specifically, the installation instructions

  https://fedorahosted.org/spacewalk/wiki/HowToInstall

assume that you don't have extra yum repos configured beyond those specified on this page for those various versions of operating systems. If you have extra repos, it's really up to you to figure out in what way they affect the yum transaction.

Note You need to log in before you can comment on or make changes to this bug.