Bug 824416 - RFE: Support partition enlargement
RFE: Support partition enlargement
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 08:28 EDT by Kamil Páral
Modified: 2013-01-30 07:33 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-30 06:55:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug video demonstration (931.86 KB, video/ogg)
2012-05-23 08:28 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-05-23 08:28:35 EDT
Created attachment 586332 [details]
bug video demonstration

Description of problem:
Standard partition can only be shrinked, it can't be enlarged. See attached video.

This can be a problem during installation, when somebody wants to re-do his disk layout and install Fedora at the same time.

Example use case: I have a 20GB partition "/home" (standard, not LVM) and I realized I need it larger for Fedora 17. Anaconda doesn't allow me to enlarge it.

Possible workaround 1: Enlarge the partition after install. This doesn't work if anaconda placed further partitions after that particular one (you would have to shift all partitions to the right, which is painful. Also it invalidates UUIDs).

Possible workaround 2: Create your disk layout before booting Anaconda. Somewhat silly.

Version-Release number of selected component (if applicable):
F17 RC4
anaconda 17.29

How reproducible:
always

Steps to Reproduce:
1. edit a standard partition
2. try to enlarge it
Comment 1 Kamil Páral 2012-05-23 08:29:40 EDT
Proposing as F17Blocker for discussion.
Comment 2 Peter Jones 2012-05-23 08:49:07 EDT
I'd agree that this is is a bug, but I wouldn't say it's a blocker what with the numerous obvious workarounds and it not being something you do on most installs.
Comment 3 Peter Jones 2012-05-23 08:53:38 EDT
Nix that - we haven't ever supported this in the UI.  So this is a valid feature request, but it's not a bug and certainly not a blocker.
Comment 4 Kamil Páral 2012-05-23 09:30:11 EDT
Because according to developers this was never supported in Anaconda (so it would be a new feature and not anything to be quickly fixed), I'm removing the Blocker proposal.

Changing summary to RFE.
Comment 5 Adam Williamson 2012-05-23 12:52:43 EDT
Also note that we explicitly don't 'support' resizing in the criteria at all - not even shrinking.
Comment 6 Chris Lumens 2013-01-29 13:52:34 EST
It'd be worth someone retesting this with F18.
Comment 7 Kamil Páral 2013-01-30 06:55:11 EST
It is possible to resize a partition in anaconda 18. But it is _very_ hard to do, because I stumbled upon excessive number of bugs in the process and I had to try several ways of achieving it.

Closing this bug, it's solved. I'll open a new report about the issues I have found.

Note You need to log in before you can comment on or make changes to this bug.