Bug 824464 - [abrt] bluefish-2.0.3-6.fc16: bftextview2_run_scanner: Process /usr/bin/bluefish was killed by signal 11 (SIGSEGV)
[abrt] bluefish-2.0.3-6.fc16: bftextview2_run_scanner: Process /usr/bin/bluef...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: bluefish (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
abrt_hash:e2f392344a6fe420dfe617cf8a9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 10:12 EDT by reis.lucia
Modified: 2012-08-24 07:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-24 07:58:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (7.04 KB, text/plain)
2012-05-23 10:12 EDT, reis.lucia
no flags Details
File: backtrace (61.78 KB, text/plain)
2012-05-23 10:12 EDT, reis.lucia
no flags Details
File: maps (24.52 KB, text/plain)
2012-05-23 10:12 EDT, reis.lucia
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 679402 None None None 2012-07-04 11:47:00 EDT

  None (edit)
Description reis.lucia 2012-05-23 10:12:18 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        bluefish '/home/lucia/mobi7/O que Einstein disse a seu cozinheiro - 2 - Robert L. Wolke.html'
comment:        bluefish has crashed after I tried to open an html file
crash_function: bftextview2_run_scanner
executable:     /usr/bin/bluefish
kernel:         3.3.5-2.fc16.i686
pid:            16495
reason:         Process /usr/bin/bluefish was killed by signal 11 (SIGSEGV)
time:           Wed 23 May 2012 10:59:57 AM BRT
uid:            1000

backtrace:      Text file, 63265 bytes
dso_list:       Text file, 7208 bytes
maps:           Text file, 25109 bytes

build_ids:
:b5d8dba6c9d0548815a8aa120f136a6c125c21e1
:1af5458157158b2b723d392187198a375d2c1ac7
:e86c829bf8553d6b593dbd8c4df0957268dc8328
:ec28befdf5ff57fdc7e4f444d594e86f5b1a9f23
:b51d82e58cf1d3dab20e44b114cfcf7ee1f31c74
:96b666a7f6d7a80ea6f9aef54f0cdd0f6190c058
:c9bedc7ec229b2a2e2ec1b6a6581b415c98bc4c1
:a031ec247ebfa2c35d637f0c427474d7a0e43904
:4c04033d01a9d6b157b2521ae3409a0ba0f5f3a3
:92418f7b783e29ab8440148e3fb0cbcfb8bb354a
:1002abe0291e2b40a073f1d82ed0322e82a760dc
:3aed71a6e79a28101ca36e6e9b3e8e053b73421a
:b2d5c5f02b6e6eb34dc593699c0b0bf516280159
:a0b366e13cecd6a811ac0afa3481d443b583aa4c
:17d83b9cb053e924459aec2a36298787a49622a3
:349bfa0620975123ec3450d56a691428a140a39b
:9377a2f0ad2727a4aa60ea32eddb2543cced5f07
:9b74e05fa75cf73df1da0c05a7b1528f0ec8a0f0
:42859023e4ec83a16446984b1e0c7510a38731c4
:647951954dab9eadcf521b97c5f9d7566b1e79c8
:66bde8f1c5ea0505d428ab205352524e2ccfa7ac
:068a08df7c2b31b4e13fb0df22c42ba2b51baa9d
:b15b3676f0d78173fc1a46eb9e7e32f4b3cca6bb
:05b2dae15e59dce2c8918febf3a4d6644883fec1
:d2fa47ac2ef035e4573199292f6d6352a0132124
:8f59113fbe384fbd55c65585d58dec2cdcb5cf00
:7a45666a014481c196c7f53a4aef302b0331aaf3
:917b19e34a4e653ea2f5151867bfb15e683a008d
:c1f38a32c6faaa1930eff465aa7bc843af7b6360
:7523f9012d700a579c80e83f54445e7bfceb4eca
:ee6ae8e1a136e74409eada175f62e7a04141e210
:2c4e6e5956dc136a43a31e33e4796e16fc35b5cc
:6ecdde4147fa0e931f02dbd92c5a6c58709b4e9f
:2db77e82f9cf6054c8c51f0e059ff75075dbbc36
:52cfde7a730826ca63e9d6de254413e8e20d6fc4
:60e488e737928d97c52bed9d28e5c9c4ec4a821a
:20e55e40b2f98606fcb0891424b09eb7e723ce8f
:82ea127e66293fd5449225991b20eff9e9f87e14
:63dd827dee72af944147d4f6df04266e0765a7b7
:19bce624dda8659f770012166d85bc075fb23f1a
:ffcce0ef31fcad3e583b63ce7f8d4dbae334eb54
:5b853064c3d832d471e71bb67b714a7f69ff11d3
:15bab279752ad8e30f901abae77bcb1ed1f38977
:6400f8b1506a2b01270ddb7fa0d07487fc7dbaa6
:23d1086014ed5544b3df4cee1f95694032252322
:c36985d76169b6d68cc22962b532889701f7d4aa
:5184e7abe1d7f341285b2d4c74d7f31137849454
:ced82078ed2f1dd18f92fb24bf6b760a4f5b178c
:faa844e460702359079f4f15f1f881e87777abb6
:7797557c8de2017a8a26fca60803b0ca826bd835
:5031c4c03882fc3c5cc3dd84e2b4491d8bd08af3
:4cadcee4cbcd48d8b8766361bf2e80d593a46536
:bdbcb7ad0ae16806e9002af3c6d1ec65353108a0
:8a257536ca5f5aee876e236d9bab65868b0b385f
:2aed5f2860186d237ceea6f6d26c433204f9d5a1
:8403f33f0be1a3653acd05b560f87aa1363d02d7
:84b057caeb7f80b34a00c58b3684cc85c66651c3
:a861dd64efbed0e35b4cdad337313b98c162cf58
:82674b49345364df4c158e8258b93fd4d8fdbae0
:1c92bde3bc752e5630e24d8699a50bcff735af0b
:e42d500dc9e803be62453540b4c81a12e96a006a
:4f7e89065d13e6332d922afbb029edbd539e6b9c
:872fe6020efffe0829a231da5dd4e51f41a4dce3
:d94f52f020f5a21d89ce70745a9bfb78cee38ba4
:4b65b2ab36082e9552ad2014fac436421c4f65ad
:0351a659bc0812678c67f62af1f802a5f367befc
:70ec0be07448920a83c0bceafed09d46008e56b1
:798697a352bae4178953ba502fb04f33dd0ed987
:10cec21724c13b95ec03f00985b0405412817a49
:dd4b5e7b0263e852bbd890ca6358ccc7075fe18b
:1ecbaf5c5ac1f22012c83df335687b3c09ae5289
:1e433d5156c8decab4ff0f1125eefb5a5bef4622
:4b045111479e1ec97d0ef5668482bf808e8dadba
:55433495aa80cf9e1f994ea7e7ae278422ef1ede
:83828a31823ccb1a2e2f04736f01f6c41ba1e360

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=jarvis
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=ea04a761f6761ba8673d09b60000000d-1337773533.708698-1034517155
:GNOME_KEYRING_CONTROL=/tmp/keyring-dzdYgz
:IMSETTINGS_MODULE=IBus
:USER=lucia
:USERNAME=lucia
:MAIL=/var/spool/mail/lucia
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/lucia/.local/bin:/home/lucia/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/lucia
:XMODIFIERS=@im=ibus
:GNOME_KEYRING_PID=1298
:LANG=en_US.utf8
:GDM_LANG=en_US.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/lucia
:XDG_SEAT=seat0
:SHLVL=1
:LOGNAME=lucia
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-ihE3kYH9OW,guid=8abe4153c865b3a5d1d164290000019a
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/lucia
:DISPLAY=:0.0
:XAUTHORITY=/var/run/gdm/auth-for-lucia-QmDbL8/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1307,unix/unix:/tmp/.ICE-unix/1307
:SSH_AUTH_SOCK=/tmp/keyring-dzdYgz/ssh
:GPG_AGENT_INFO=/tmp/keyring-dzdYgz/gpg:0:1
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/bluefish.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=16495
:DESKTOP_STARTUP_ID=nautilus-2632-jarvis-bluefish-5_TIME8252449

var_log_messages:
:May 23 10:59:57 jarvis kernel: [ 8473.843952] bluefish[16495]: segfault at 10 ip 080705bb sp bffbbdb0 error 4 in bluefish[8048000+8a000]
:May 23 11:00:05 jarvis abrt[16634]: Saved core dump of pid 16495 (/usr/bin/bluefish) to /var/spool/abrt/ccpp-2012-05-23-10:59:57-16495 (427372544 bytes)

xsession_errors:
:** (bluefish:16380): WARNING **: no configfile rcfile-2.0, try to convert config files from older versions
:Language statistics for XHTML from /usr/share/bluefish/bflang//xhtml.bflang2
:** (bluefish:16380): WARNING **: error getting file info for file:///home/lucia/mobi7/The%20Dark%20Side%20of%20the%20Moon%20-%20John%20Harris.html: Error stating file '/home/lucia/mobi7/The Dark Side of the Moon - John Harris.html': No such file or directory
:** (bluefish:16380): WARNING **: while opening file, received error 1: Error opening file: No such file or directory
:Language statistics for Generic HTML from /usr/share/bluefish/bflang//html.bflang2
:** (bluefish:16495): WARNING **: no configfile rcfile-2.0, try to convert config files from older versions
:Language statistics for Generic HTML from /usr/share/bluefish/bflang//html.bflang2
:** (bluefish:16495): WARNING **: while checking file modification on disk, received error 19: Operation was cancelled
:(bluefish:16495): Gtk-WARNING **: Invalid text buffer iterator: either the iterator is uninitialized, or the characters/pixbufs/widgets in the buffer have been modified since the iterator was created.
:** (bluefish:16641): WARNING **: no configfile rcfile-2.0, try to convert config files from older versions
:sending files to existing bluefish process... done
:** (bluefish:16746): WARNING **: no configfile rcfile-2.0, try to convert config files from older versions
:Language statistics for Generic HTML from /usr/share/bluefish/bflang//html.bflang2
:** (bluefish:16979): WARNING **: no configfile rcfile-2.0, try to convert config files from older versions
:Language statistics for Generic HTML from /usr/share/bluefish/bflang//html.bflang2
Comment 1 reis.lucia 2012-05-23 10:12:31 EDT
Created attachment 586364 [details]
File: dso_list
Comment 2 reis.lucia 2012-05-23 10:12:36 EDT
Created attachment 586365 [details]
File: backtrace
Comment 3 reis.lucia 2012-05-23 10:12:46 EDT
Created attachment 586366 [details]
File: maps
Comment 4 Paul Howarth 2012-06-19 10:42:53 EDT
Is this crash repeatable if you try to open the same file again?
Comment 5 Paul Howarth 2012-08-24 07:58:23 EDT
Upstream believes that this is fixed in bluefish 2.2.x, which is available in Fedora 17. I'm reluctant to update Fedora 16 to 2.2.x as there are UI changes that would violate the Fedora Updates Policy (http://fedoraproject.org/wiki/Updates_Policy#Stable_Releases).

Please consider updating to Fedora 17.

Note You need to log in before you can comment on or make changes to this bug.