Bug 824473 - listing repos to be synced fails
listing repos to be synced fails
Status: CLOSED NOTABUG
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: wes hayutin
mkovacik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 10:39 EDT by wes hayutin
Modified: 2012-05-23 12:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-23 12:29:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2012-05-23 10:39:38 EDT
Description of problem:

pulp remote rhui branch commit 57e85236ce2dd87d1452773826d7c52e99bb2e9a
cloude master commit 4091449016baf15696fa7d2013ed5653963acfac

1. upload entitlement cert
2. add redhat repos
3. try to sync


Unexpected error caught at the shell level
Traceback (most recent call last):
  File "/home/whayutin/workspace/cloude/rhui-2.0/tools/src/rhui/tools/shell.py", line 85, in safe_listen
    self.listen(clear=first_run)
  File "/home/whayutin/workspace/cloude/rhui-2.0/tools/src/rhui/tools/shell.py", line 111, in listen
    Shell.listen(self)
  File "/home/whayutin/workspace/cloude/rhui-2.0/tools/src/rhui/common/shell.py", line 191, in listen
    item.func(*args, **item.kwargs)
  File "/home/whayutin/workspace/cloude/rhui-2.0/tools/src/rhui/tools/screens/sync.py", line 93, in repo_display
    self.pulp.repos_with_sync_status, False)
  File "/home/whayutin/workspace/cloude/rhui-2.0/tools/src/rhui/tools/screens/sync.py", line 374, in _sync_display
    data_sets = retrieve_func()
  File "/home/whayutin/workspace/cloude/rhui-2.0/tools/src/rhui/tools/pulp_api.py", line 224, in repos_with_sync_status
    full_repo = self.repo(repo['id'])
  File "/home/whayutin/workspace/cloude/rhui-2.0/tools/src/rhui/tools/pulp_api.py", line 131, in repo
    raise e
ServerRequestError: (500, u"AttributeError: 'NoneType' object has no attribute 'find'", u'Traceback (most recent call last):\n  File "/home/whayutin/workspace/pulp/src/pulp/server/webservices/controllers/decorators.py", line 48, in report_error\n    return method(self, *args, **kwargs)\n  File "/home/whayutin/workspace/pulp/src/pulp/server/webservices/controllers/decorators.py", line 127, in _auth_decorator\n    value = method(self, *args, **kwargs)\n  File "/home/whayutin/workspace/pulp/src/pulp/server/webservices/controllers/repositories.py", line 428, in GET\n    task = scheduled_sync.find_scheduled_task(repo[\'id\'], \'_sync\')\n  File "/home/whayutin/workspace/pulp/src/pulp/server/api/scheduled_sync.py", line 148, in find_scheduled_task\n    for task in async.find_async(method_name=method_name):\n  File "/home/whayutin/workspace/pulp/src/pulp/server/async.py", line 110, in find_async\n    return _queue.find(**kwargs)')
Comment 1 wes hayutin 2012-05-23 11:50:50 EDT
the repos that were added were not originally correct added.. hence causing this issue..

using the rhui try and delete these repos also fails:


==> /var/log/pulp/pulp.log <==
2012-05-23 11:48:59,495 8175:140262617396992: pulp.server.webservices.controllers.decorators:ERROR: decorators:52 Traceback (most recent call last):
  File "/home/whayutin/workspace/pulp/src/pulp/server/webservices/controllers/decorators.py", line 48, in report_error
    return method(self, *args, **kwargs)
  File "/home/whayutin/workspace/pulp/src/pulp/server/webservices/controllers/decorators.py", line 127, in _auth_decorator
    value = method(self, *args, **kwargs)
  File "/home/whayutin/workspace/pulp/src/pulp/server/webservices/controllers/repositories.py", line 544, in DELETE
    task = async.run_async(api.delete, args=[id])
  File "/home/whayutin/workspace/pulp/src/pulp/server/async.py", line 98, in run_async
    return enqueue(task, unique)
  File "/home/whayutin/workspace/pulp/src/pulp/server/async.py", line 58, in enqueue
    _queue.enqueue(task, unique)
AttributeError: 'NoneType' object has no attribute 'enqueue'


==> /var/log/httpd/error_log <==
[Wed May 23 11:48:59 2012] [error] 2012-05-23 11:48:59,495 pulp.server.webservices.controllers.decorators:ERROR: Traceback (most recent call last):
[Wed May 23 11:48:59 2012] [error]   File "/home/whayutin/workspace/pulp/src/pulp/server/webservices/controllers/decorators.py", line 48, in report_error
[Wed May 23 11:48:59 2012] [error]     return method(self, *args, **kwargs)
[Wed May 23 11:48:59 2012] [error]   File "/home/whayutin/workspace/pulp/src/pulp/server/webservices/controllers/decorators.py", line 127, in _auth_decorator
[Wed May 23 11:48:59 2012] [error]     value = method(self, *args, **kwargs)
[Wed May 23 11:48:59 2012] [error]   File "/home/whayutin/workspace/pulp/src/pulp/server/webservices/controllers/repositories.py", line 544, in DELETE
[Wed May 23 11:48:59 2012] [error]     task = async.run_async(api.delete, args=[id])
[Wed May 23 11:48:59 2012] [error]   File "/home/whayutin/workspace/pulp/src/pulp/server/async.py", line 98, in run_async
[Wed May 23 11:48:59 2012] [error]     return enqueue(task, unique)
[Wed May 23 11:48:59 2012] [error]   File "/home/whayutin/workspace/pulp/src/pulp/server/async.py", line 58, in enqueue
[Wed May 23 11:48:59 2012] [error]     _queue.enqueue(task, unique)
[Wed May 23 11:48:59 2012] [error] AttributeError: 'NoneType' object has no attribute 'enqueue'
[Wed May 23 11:48:59 2012] [error] 

==> /var/log/httpd/ssl_access_log <==
10.11.228.65 - - [23/May/2012:11:48:59 -0400] "DELETE /pulp/api//repositories/rhel-x86_64-5-rhui-1-rpms-5Server-i386/ HTTP/1.1" 500 849

==> /var/log/httpd/ssl_request_log <==
[23/May/2012:11:48:59 -0400] 10.11.228.65 SSLv3 DHE-RSA-AES256-SHA "DELETE /pulp/api//repositories/rhel-x86_64-5-rhui-1-rpms-5Server-i386/ HTTP/1.1" 849
Comment 2 wes hayutin 2012-05-23 12:29:38 EDT
A user can only get into this mess if there are stale repo's listed in the db.  
That would be the root cause, closing this bug, looking for root cause

Note You need to log in before you can comment on or make changes to this bug.