Bug 824474 - Plugin pack for JDG does not contain proper JDG plugin
Plugin pack for JDG does not contain proper JDG plugin
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JDG (Show other bugs)
JON 3.1.0
Unspecified Unspecified
urgent Severity high
: ---
: JON 3.1.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: jon310-sprint11/rhq44-sprint11
  Show dependency treegraph
 
Reported: 2012-05-23 10:42 EDT by Martin Gencur
Modified: 2013-09-11 07:01 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-11 07:01:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Gencur 2012-05-23 10:42:53 EDT
Description of problem:

The plugin pack for JDG (
http://download.devel.redhat.com/brewroot/packages/org.jboss.on-jboss-on-parent/3.1.0.ER4/1/maven/org/jboss/on/jon-plugin-pack-jdg/3.1.0.ER4/jon-plugin-pack-jdg-3.1.0.ER4.zip ) contains infinispan-rhq-plugin which is not usable for standalone JDG server. 

The correct plugin is called jboss-datagrid-rhq-plugin and current version can be downloaded from http://download.devel.redhat.com/devel/candidates/JDG/JDG-6.0.0-ER10/jboss-datagrid-rhq-plugin-6.0.0.ER10.zip

Please contact ttarrant@redhat.com for next releases of the plugin.

The infinispan-rhq-plugin could be potentially used in library mode of JDG but I have not tested this and don't know what is the status of the plugin.
Comment 1 Mike Foley 2012-05-23 10:46:39 EDT
setting priority to URGENT as this blocks JON 3.1
Comment 2 John Sanda 2012-05-25 10:36:57 EDT
The changes have been made so that now the data grid plugin pack includes the following,

groupId: com.jboss.datagrid
artifactId: jboss-datagrid-rhq-plugin
version: 6.0.0.ER10-redhat-1

This change will get included in the ER5 build.
Comment 3 John Sanda 2012-05-25 10:37:26 EDT
Moving to ON_QA since the ER5 build is now available.

Note You need to log in before you can comment on or make changes to this bug.