Bug 824479 - [RFE] Allow for hooks within workflow
[RFE] Allow for hooks within workflow
Status: CLOSED DUPLICATE of bug 823581
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Angus Thomas
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 10:54 EDT by james labocki
Modified: 2012-07-13 09:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-13 09:40:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james labocki 2012-05-23 10:54:36 EDT
Description of problem:
This is a request for a framework which allows hooks to be executed within all parts of workflows. This framework would allow for third party tools to be easily integrated with CloudForms.

Example Story: When the launch button is selected a hook is called (start_launch) which executes a script (created by customer, consultant, or third party software vendor). This script would insert a record into a third party tool (such as remedy or BMC). Cloud Engine would not launch the instance, instead it would set the status to "waiting for response from $hook_name". Upon completion of workflow in third party tool the third party tool would call Cloud Engine API and change the status from "waiting for response from $hook_name" to "approved". At this point, Cloud Engine would launch the instance.
Comment 1 Dave Johnson 2012-07-13 09:40:53 EDT

*** This bug has been marked as a duplicate of bug 823581 ***

Note You need to log in before you can comment on or make changes to this bug.