This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 82449 - Top level Makefile has rpm problem
Top level Makefile has rpm problem
Status: CLOSED DUPLICATE of bug 82448
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-22 04:19 EST by Ravindranadh Chowdary
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:51:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ravindranadh Chowdary 2003-01-22 04:19:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:

I am using Redhat kernel sources Version-2.4.18-14. I am not able to create a
kernel rpm using make rpm command in RedHat-8.0. reporting rpm -ta is an unknown
option. Cd to linux and execute a command as follows

#make rpm
...............................
...............................
kernel-2.4.1814custom/./scripts/tkgen.c
kernel-2.4.1814custom/./scripts/tkparse.c
kernel-2.4.1814custom/./scripts/tkparse.h
kernel-2.4.1814custom/./scripts/ver_linux
kernel-2.4.1814custom/./kernel.spec
-ta: unknown option
make: *** [rpm] Error 1

The make file is working perfactly if rpm replaced with rpmbuild.

Could you please resolve this.

Regards
Ravi

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.cd /usr/src/linux
2.make rpm
3.
    

Actual Results:  Exiting with following error.

-ta: unknown option
make: *** [rpm] Error 1

Expected Results:  Creates a Kernel RPM

Additional info:
Comment 1 Jakub Jelinek 2003-01-26 17:03:44 EST
Doesn't sound like a bug in make itself...
Comment 2 Alan Cox 2003-06-08 12:21:28 EDT

*** This bug has been marked as a duplicate of 82448 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:51:18 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.