This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 824509 - (solaris only) agent only detects jmx-enabled processes own by agent user
(solaris only) agent only detects jmx-enabled processes own by agent user
Status: CLOSED NOTABUG
Product: JBoss Operations Network
Classification: JBoss
Component: Agent (Show other bugs)
JON 3.1.0
x86_64 Solaris
high Severity high
: ---
: JON 3.2.0
Assigned To: Thomas Segismont
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 11:54 EDT by Viet Nguyen
Modified: 2013-09-13 06:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-13 06:05:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Viet Nguyen 2012-05-23 11:54:17 EDT
Description of problem:
In Solaris 11 agent only detects local jmx processes own by agent user not by other users.


Version-Release number of selected component (if applicable):
JON 3.1 ER4
Solaris 11 i386
JDK 1.6.0.26 b03

How reproducible:
100%

Steps to Reproduce:
1. As agent user run a java program with jxm enabled eg
-Dcom.sun.management.jmxremote.port=45123 -Dcom.sun.management.jmxremote.authenticate=false -Dcom.sun.management.jmxremote.ssl=false

2. run agent discovery. verify the java process is being detected

3. As another user run the same java program with different jmxremote port

4. run agent discovery
  
Actual results:
agent does not detect jmx processes owned by non-agent user

Expected results:
In RHEL6 and windows2007 agent detects all local jmx processes regardless of process owner. 

Additional info:
Comment 1 Mike Foley 2012-05-29 10:41:08 EDT
per BZ Triage 5/29/2012 (ccrouch, loleary, asantos, mfoley, myarborough) moving these to JON 3.1.1 or later
Comment 3 Thomas Segismont 2013-09-13 06:05:59 EDT
This is not a bug, you must give the user running the agent sufficient permissions or run it as root (edit /etc/user_attr file and give proc_owner privilege to the user running the agent)

See https://jira.hyperic.com/browse/SIGAR-101

Note You need to log in before you can comment on or make changes to this bug.