Bug 824521 - Applications do not work after creating from template
Applications do not work after creating from template
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Krishna Raman
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 12:29 EDT by Fotios Lindiakos
Modified: 2015-05-14 21:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 13:59:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Broker log (7.20 KB, application/octet-stream)
2012-05-23 12:29 EDT, Fotios Lindiakos
no flags Details
Application log (2.81 KB, text/plain)
2012-05-23 12:29 EDT, Fotios Lindiakos
no flags Details
Broker log (7.20 KB, text/plain)
2012-05-23 12:30 EDT, Fotios Lindiakos
no flags Details

  None (edit)
Description Fotios Lindiakos 2012-05-23 12:29:14 EDT
Created attachment 586405 [details]
Broker log

Description of problem:
After creating an application based on an application template, the new applications do not work. For example in a Rails application, it complains about not being able to find the rake gem. This is probably caused by the .openshift/action_hooks not being executed.


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Deploy application based on template
2. Navigate to application URL
3.
  
Actual results:
Passenger error about not being able to find rake
(Similar errors for other templates)

Expected results:
Application should work


Additional info:
Attached are logs from the broker (for when the application is created) and from the application itself.
Comment 1 Fotios Lindiakos 2012-05-23 12:29:54 EDT
Created attachment 586406 [details]
Application log
Comment 2 Fotios Lindiakos 2012-05-23 12:30:49 EDT
Created attachment 586407 [details]
Broker log
Comment 3 Fotios Lindiakos 2012-05-23 14:45:59 EDT
Confirmed that by pushing to the repo, the action_hooks are triggered and the application will function properly. This was testing on a Rails app.
Comment 4 Krishna Raman 2012-05-30 12:18:22 EDT
https://github.com/openshift/crankcase/pull/70
Comment 5 Rony Gong 2012-05-31 06:21:15 EDT
verified on devenv_1809
Steps:
1.create template by yaml file:
Vendor: unknown
Requires:
- php-5.3
Architecture: noarch
Description:
License: unknown
Subscribes:
  doc-root:
    Required: false
    Type: FILESYSTEM:doc-root
Version: 0.0
2.then create app by this template
3.access app, show content "Error establishing a database connection"

Note You need to log in before you can comment on or make changes to this bug.