Bug 824550 - [RFE] Drift Management: Compare System to Template
[RFE] Drift Management: Compare System to Template
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Og Maciel
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 13:56 EDT by james labocki
Modified: 2014-09-08 14:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-08 14:27:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james labocki 2012-05-23 13:56:44 EDT
This is a RFE to provide a mechanism, to quickly see if a system conforms to specification or not. Make sure RPMs & config files are as expected or not. For RPM you could build release rpms that hold the certified software including versions as requirements. That way you'll see quickly if the systems complies or not. This would also help to prevent unwanted software changes on this system. The config file compliance could probably been checked when puppet gets integrated. In larger customer environments this is a vital feature to keep the environment manageable over time. With this i can easily determine my one-offs. And fix them.
Comment 2 Bryan Kearney 2014-09-08 14:27:13 EDT
You could do this with puppet today. Since there are no templates any longer in Satellite 6.0, I am going to close this out. If you disagree with this please feel free to re-open.

Note You need to log in before you can comment on or make changes to this bug.