Bug 824618 - yum: local variable 'found' referenced before assignment
yum: local variable 'found' referenced before assignment
Status: CLOSED DUPLICATE of bug 752407
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 16:35 EDT by Pavel Alexeev
Modified: 2014-01-21 18:22 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-24 02:43:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Alexeev 2012-05-23 16:35:43 EDT
Description of problem:
# LANG=C yum --installroot=/mnt/root distro-sync full
Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Distribution Synchronization Process
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 140, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 462, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 462, in doCommand
    return base.distroSyncPkgs(extcmds)
  File "/usr/share/yum-cli/cli.py", line 914, in distroSyncPkgs
    if found:
UnboundLocalError: local variable 'found' referenced before assignment

Version-Release number of selected component (if applicable):
# rpm -q yum
yum-3.4.3-5.fc16.noarch

From Fedora 16 Live.

How reproducible:
Always.
Comment 1 Zdeněk Pavlas 2012-05-24 02:43:20 EDT

*** This bug has been marked as a duplicate of bug 752407 ***

Note You need to log in before you can comment on or make changes to this bug.