Bug 824705 - Mounting and umounting frequently exhausts LowFree [NEEDINFO]
Mounting and umounting frequently exhausts LowFree
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.4
i686 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 23:16 EDT by Menghuan Wong
Modified: 2014-06-02 09:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:06:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (silver.wmh)


Attachments (Terms of Use)

  None (edit)
Description Menghuan Wong 2012-05-23 23:16:33 EDT
Description of problem:
Mounting and umounting a partition frequently(e.g., autofs) will decrease the LowFree of memory, and it won't go up. When the value of LowFree is very small, oom-killer will be triggered, and then other progresses will be killed.

Version-Release number of selected component (if applicable):
mount (util-linux 2.13-pre7)

How reproducible:
100%

Steps to Reproduce:
1.
watch 'cat /proc/meminfo | grep LowFree'

2.
I use default timeout(5min) of autofs, it will be reproduced in 51 days.
I tried the way below, and it will reproduced in several hours.

while [ true ]; do
    mount /dev/sdb1 /mnt
    umount /mnt
done

  
Actual results:
Lowfree reduced to 8M, other progresses are killed by oom-killer.

Expected results:
Lowfree decreased while mounting,but it should go up after umounting.

Additional info:
Comment 1 RHEL Product and Program Management 2014-03-07 07:43:19 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 2 RHEL Product and Program Management 2014-06-02 09:06:52 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.