Bug 824717 - Feature reqeust: Firefox user agent fedora branding
Feature reqeust: Firefox user agent fedora branding
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
17
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 23:59 EDT by Piruthiviraj Natarajan
Modified: 2012-06-21 09:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-21 09:31:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piruthiviraj Natarajan 2012-05-23 23:59:00 EDT
Description of problem:

Since Fedora 15, there is no branding in firefox in its user agent. Most of the market share studies on operating systems are based on user agent and having a branding is good to spread  fedora. Its not obtrusive to any of the features of fedora and has no performance penalty of having a user agent with fedora branding the browser. Other major distros have their branding in user agent.
Comment 1 Martin Stransky 2012-05-24 03:53:12 EDT
Can you provide a list of distros and their user-agents? I'm aware of Ubuntu only.
Comment 2 Piruthiviraj Natarajan 2012-05-24 04:49:12 EDT
debian with iceweasel, Freebsd. linux mint,opensuse.

It doesn't even matter if others have it or not, the point is Fedora had it once and now it has been removed. If its not too much trouble to have a name in the user agent, it would be nice.
Comment 3 Martin Stransky 2012-05-24 05:00:01 EDT
Please, attach the user agent strings which are used by those distributions. And yes, it matters, generally we don't want to change the generic UA strings, it breaks internet privacy and you can be easily identified by your browser fingerprint.
Comment 4 Piruthiviraj Natarajan 2012-05-24 05:17:45 EDT
[code]Mozilla/5.0 (X11; Linux x86_64; rv:10.0.4) Gecko/20100101 Firefox/10.0.4 Iceweasel/10.0.4[/code]

I have only debian useragent available right now. Others I shall post later.

You have a valid point when you say you can be identified by your browser fingerprint. I 'm not sure if it has so much value because  you have all other info about your system in the useragent except for the name fedora.
Comment 5 Martin Stransky 2012-06-21 09:31:03 EDT
Closing as WONTFIX. We want to minimize browser fingerprint as much as possible.

Note You need to log in before you can comment on or make changes to this bug.