Bug 824805 - [UserPortal] When VM Pool an VM has the same name, UserPortal extended view freezes
[UserPortal] When VM Pool an VM has the same name, UserPortal extended view f...
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-userportal (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.1
Assigned To: Tomas Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-24 06:10 EDT by Tomas Jelinek
Modified: 2012-08-09 04:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 04:06:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Jelinek 2012-05-24 06:10:09 EDT
Steps to Reproduce:
1. Create a VM named "some" and VM Pool named "some"
2. Give them proper permissions so the UserPortal's extended view's VM side tab will show them (note that unlike WebAdmin, UserPortal's VM side tab shows both VMs and Pools)
3. Open UserPortal extended view
  
Actual results:
The window freezes

Additional info:

The problem is in the org.ovirt.engine.ui.uicommonweb.Linq class in the Sort method called from the UserPortalListModel.OnVmAndPoolLoad(). This sort method can not deal with the situation that two values are equal and causes infinite loop.
Comment 1 Tomas Jelinek 2012-05-24 08:04:22 EDT
in gerrit: http://gerrit.ovirt.org/#change,4754
Comment 2 vszocs 2012-05-25 11:49:22 EDT
Patch merged upstream.
Comment 3 Itamar Heim 2012-08-09 04:06:27 EDT
closing ON_QA bugs as oVirt 3.1 was released:
http://www.ovirt.org/get-ovirt/

Note You need to log in before you can comment on or make changes to this bug.