Bug 824809 - network not enabled after install
network not enabled after install
Status: CLOSED DUPLICATE of bug 693602
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On: 602185
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-24 06:26 EDT by Karel Volný
Modified: 2012-05-29 11:42 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 602185
Environment:
Last Closed: 2012-05-24 07:04:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2012-05-24 06:26:57 EDT
bug #602185 talks about several issues, one of them is that network is not enabled after installation

I refer to bug #557112 comment #9 - using kickstart is a workaround, not a solution, and I'd like to see this resolved

I've hit the problem trying to install F17 from a DVD

I've setup my networking in the installer and got the repositories loaded from the Internet without any problem

while setting the networking I've chosen that it is a system connection (or what was the checkbox description?), yet after reboot the networking wasn't activated - I had to use "chkconfig network on"

if Anaconda is able to copy the networking settings (I use static settings) then it should be able also to copy the information that it should be used as a system connection and make it on by default

note also that I did minimal install, which does NOT include networkmanager, yet  ifcfg-eth0 included the line 'NM_CONTROLLED="yes"' - this should be fixed along

+++ This bug was initially created as a clone of Bug #602185 +++
Comment 1 Radek Vykydal 2012-05-24 07:04:48 EDT
The problem is network service being disabled, NM_CONTROLLED setting is irrelevant here. For more details please see bz I'm dupeing this one to.

*** This bug has been marked as a duplicate of bug 693602 ***
Comment 2 Karel Volný 2012-05-24 07:38:41 EDT
ah, thanks, that one didn't show in my search as it is closed

however, I wonder how's that possible that I've hit a bug which should be fixed ...
Comment 3 Adam Williamson 2012-05-24 12:13:02 EDT
Every test of F17 I've done since Beta, network has been enabled after install. NetworkManager _is_ in a minimal install, with F17. If it wasn't in your installation, then you somehow removed it yourself.
Comment 4 Karel Volný 2012-05-29 06:47:49 EDT
(In reply to comment #3)
> NetworkManager _is_ in a minimal install, with F17. If it wasn't in
> your installation, then you somehow removed it yourself.

no, I haven't touched the package list

could that be that the list is not updated from the Internet? - I may have used older media (I thought it's not of importance as I was planning to do "netinstall", enabling updates during the installation)
Comment 5 Adam Williamson 2012-05-29 11:42:37 EDT
I think so, yes. I believe the package group list is on the media, not retrieved from the remote repository. Try again with a Final ISO.

Note You need to log in before you can comment on or make changes to this bug.