Bug 824851 - fv_storage test traceback if --server not set
fv_storage test traceback if --server not set
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.5
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Greg Nichols
Zhiyou Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-24 08:54 EDT by Guangze Bai
Modified: 2015-02-08 16:38 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no tech note needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 17:29:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fvtest.py patch fixing traceback (889 bytes, patch)
2012-05-29 09:22 EDT, Greg Nichols
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0711 normal SHIPPED_LIVE v7 bug fix and enhancement update 2012-06-05 21:26:37 EDT

  None (edit)
Description Guangze Bai 2012-05-24 08:54:12 EDT
Description of problem:

# v7 plan
# v7 run -t fv_storage
running fv_storage on 
sh: kudzu: command not found
installing test from /usr/share/v7/tests/fv_storage into /tmp/v7-fv_storage-lqZPrV
mkdir -p /tmp/v7-fv_storage-lqZPrV
cp -a runtest.sh fv_storage.py Makefile /tmp/v7-fv_storage-lqZPrV
chmod a+x ./runtest.sh ./fv_storage.py
Test Parameters: DEBUG=off RUNMODE=normal UDI= DEVICE= OUTPUTFILE=/var/log/v7/runs/1/fv_storage/output.log 
/proc/cpuinfo has vmx flag
Testing kvm virtualization
Starting libvirtd daemon: 
libvirtd is running
Verified that guest v7x86_64 is not running
Verified: /var/lib/libvirt/images/v7data.img
Verified: /var/lib/libvirt/images/v7x86_64.img
Verified: /etc/libvirt/qemu/v7x86_64.xml
Guest files verified
Unmounting /mnt
Using loopback device /dev/loop0 for guest data image
add map loop0p1 (253:3): 0 192717 linear /dev/loop0 63
Mounted /dev/mapper/loop0p1 on /mnt
v7 image: host: v7-1.5-22, guest: v7-1.5-22  build:  2012-04-26 15:08:04
Traceback (most recent call last):
  File "/usr/bin/v7", line 45, in <module>
    success = v7.do(args)
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 194, in do
    result = self.commands[self.command]()
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 670, in doRun
    return self._doRun(tests)       
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 774, in _doRun
    returnValue = self.runTest(tmpDirectory, test, run, outputFilePath)
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 1210, in runTest
    rv = test.run()
  File "/usr/share/v7/lib/v7/fvtest.py", line 544, in run
    if not self.submitTasks():
  File "/usr/share/v7/lib/v7/fvtest.py", line 355, in submitTasks
    commandToRun = self.v7CommandInGuest + "  --mode auto --test " + self.testToRun + ' --server ' + self.getTestServer()
TypeError: cannot concatenate 'str' and 'NoneType' objects

Version-Release number of selected component (if applicable):
v7-1.5-28

How reproducible:
always


Additional info:
Comment 1 Greg Nichols 2012-05-29 09:22:33 EDT
Created attachment 587407 [details]
fvtest.py patch fixing traceback
Comment 6 Caspar Zhang 2012-06-04 04:11:07 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
no tech note needed.
Comment 8 errata-xmlrpc 2012-06-05 17:29:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0711.html

Note You need to log in before you can comment on or make changes to this bug.