Bug 824867 - Windows guest with dynamic disk can not boot on rhev after conversion by virt-p2v
Windows guest with dynamic disk can not boot on rhev after conversion by virt...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
P2V
:
Depends On:
Blocks: 1205796
  Show dependency treegraph
 
Reported: 2012-05-24 09:20 EDT by tingting zheng
Modified: 2015-11-19 01:56 EST (History)
10 users (show)

See Also:
Fixed In Version: virt-p2v-1.28.1-1.49.1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 01:56:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of windows guest with md device boot fail (91.82 KB, image/png)
2012-05-24 09:21 EDT, tingting zheng
no flags Details
p2v log for conversion of windows with MD disk (1.60 MB, text/plain)
2012-05-24 09:23 EDT, tingting zheng
no flags Details
OVF file of guest in export domain (7.23 KB, application/xml)
2012-05-24 09:24 EDT, tingting zheng
no flags Details
OVF file of guest in NFS storage (7.02 KB, application/xml)
2012-05-24 09:24 EDT, tingting zheng
no flags Details

  None (edit)
Description tingting zheng 2012-05-24 09:20:36 EDT
Description of Problem:
Windows guest with dynamic disk can not boot on rhev after conversion by virt-p2v

Version-Release number of selected component:
virt-p2v-0.8.6-5.20120502.1.el6.iso
virt-v2v-0.8.7-6.el6.x86_64
libguestfs-1.16.19-1.el6.x86_64
libvirt-0.9.10-20.el6.x86_64
augeas-0.9.0-4.el6.x86_64
febootstrap-3.12-1.el6.x86_64
hivex-1.3.3-4.el6.x86_64
libguestfs-winsupport-1.0-7.el6.x86_64
virtio-win-1.5.1-1.el6.noarch

How reproducible:
Always

Step to Reproduce:
1.Install windows on physical machine(sda1).

2.Create dynamic disk with sda2 and sda3.

3.Use virt-p2v to convert the host to rhev.

4.After conversion,import the guest and boot the guest.

Actual Results:
The guest can not boot successfully.

Expected Results:
The guest can boot successfully.

Additional info:
Windows guest with dynamic disk can be converted and boot successfully on libvirt
Comment 1 tingting zheng 2012-05-24 09:21:41 EDT
Created attachment 586630 [details]
Screenshot of windows guest with md device boot fail
Comment 2 tingting zheng 2012-05-24 09:23:06 EDT
Created attachment 586631 [details]
p2v log for conversion of windows with MD disk
Comment 3 tingting zheng 2012-05-24 09:24:01 EDT
Created attachment 586632 [details]
OVF file of guest in export domain
Comment 4 tingting zheng 2012-05-24 09:24:40 EDT
Created attachment 586633 [details]
OVF file of guest in NFS storage
Comment 9 tingting zheng 2012-06-01 06:01:25 EDT
I tested all windows guests with dynamic disk,host installed win7,win2008,win2008r2 can not boot after conversion to rhev,while host installed with winxp and win2003 can boot successfully after conversion to rhev.
Comment 11 RHEL Product and Program Management 2012-07-10 03:19:36 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 12 RHEL Product and Program Management 2012-07-10 21:58:26 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 13 RHEL Product and Program Management 2012-12-14 02:32:40 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 14 tingting zheng 2013-08-09 01:19:39 EDT
I tested to use latest virt-p2v to convert win7 host with dynamic disk to rhev,after conversion,import the guest,the guest can be booted successfully.Yet not tested other windows,if I have time I will try.

virt-p2v version:virt-p2v-0.9.1-2.20130730
Comment 15 Richard W.M. Jones 2015-03-12 13:25:15 EDT
Tingting, can you try the latest virt-p2v?
Comment 17 tingting zheng 2015-03-12 23:16:50 EDT
(In reply to Richard W.M. Jones from comment #15)
> Tingting, can you try the latest virt-p2v?

Right now are busy with rhel6.7 virt-tools testing,I will try it later.
Comment 19 Richard W.M. Jones 2015-04-16 08:15:56 EDT
This requires the ldmtool program.  It should work upstream and
in Fedora (although I've not actually tested it), but without the
package being added to RHEL 7, it's not going to work there.

I think it's probably a good idea to fix this later in RHEL 7,
but it's not something we can do for RHEL 7.2.

Moving to RHEL 7.3.
Comment 20 tingting zheng 2015-08-14 01:43:58 EDT
Tested with:
virt-p2v-1.28.1-1.49.1.el7

1.Install windows 7 32 bit on physical machine(sda1).
2.Create dynamic disk with sda2 and sda3.
3.Use virt-p2v to convert the host to rhev.
4.After conversion,import the guest and boot the guest.
5.Guest can be booted successfully on rhev.

So I think we can close this bug.
Comment 21 Richard W.M. Jones 2015-08-14 04:38:07 EDT
I'm a bit surprised it works without ldmtool.  I guess that
it works only because the systemroot disk (C: / sda) is not a
dynamic disk.  The other two disks are just treated as data.

I'm adding the bug to the erratum, as that was the original test case.

I doubt conversion of a host with dynamic disks as systemroot
would work, until we can add ldmtool to RHEL 7.
Comment 23 tingting zheng 2015-08-14 05:19:13 EDT
Refer to comment 20,move this bug to VERIFIED.
Comment 25 errata-xmlrpc 2015-11-19 01:56:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2183.html

Note You need to log in before you can comment on or make changes to this bug.