Bug 8249 - rh ppp dialer doesnt connect
rh ppp dialer doesnt connect
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-06 19:18 EST by rob
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-13 21:02:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rob 2000-01-06 19:18:13 EST
RH ppp dialer dials the number does the "handshake" and then acts as if im
connected. unable to surf the web or get email. when i ping ip's i get
unreachable error. by the way i ve spoken wiht tech support for over three
days and nothing helped.
when i use then internt connection tool in Gnome and click debug i do get
connected to the web and all works fine.. when i run ...less
/etc/wvdial.conf all then numbers and such are correct.
when i run netcfg   my search host name is local.localdomain
domain is my isp, earthlink.net
nameservers are my correct ip numbers.. in network config under interfaces
my ppp0 is there and wheni click activate it does the same thing as whne i
intiate my rh ppp dialer forom gnome. it dials and connects but doesnt let
me go anywhere.
yes i've installed the 3 updates ppp, initscripts, and rp3 ..when i run
...rpm
-q rp3 wvdial.. it comes back saying rp3-1.0.1-1    and wvdial-1.40-5
So to sum it all up , when i run network configuration tool form the gnome
footprint and click "debug" i connect and all works fine... when i try rh
ppp it calls , connects... and doesnt let me go anywhere at all. even when
i ping ip's thru my terminal .
by the way i did two clean installs to try and correct the problem.
Comment 1 Jason A. Whittle 2000-01-26 01:14:59 EST
I have an identical problem. I too have updated my system from the errata. My
syslog says that I'm connecting just fine. I shows me that it gets all of the
proper info from the Penn State servers. It logs in properly and picks up a
local IP, remote IP, and primary and secondary DNS IPs. But when I run
Navigator, it tells me that it can't resolve any names (including Penn State's
own web page and Internic's servers). I have tried telnetting to a lab on campus
that I have the IP numbers for, and telnet tells me there's no path to get there
from here (my roomie's Wintel finds it just fine.)

Oddly, the bar graph that the dialup tool runs doesn't show any activity when I
attempt to find a DNS name. It only show activity when I enter an IP address.

Additionally, I have no idea what debugging tools the originator of this bug is
talking about, so I can't get on at all. Please help.
Comment 2 Nalin Dahyabhai 2000-01-31 09:25:59 EST
I suspect your connections are working with rp3's "Debug" option and not the
normal route because rp3 actually handles Debug connections differently from
regular connections.  For regular connections, rp3 simply calls the /sbin/ifup
script, which in turn runs wvdial and pppd.  For debugging, rp3 uses its own
modified version of wvdial to control the dialing, and the differences are
probably causing the problems you're experiencing.

As of rp3-1.0.6 and wvdial-1.41-2 in Raw Hide, they are now synched, and things
work correctly with the test accounts I have access to.  Please try updating to
these versions and let me know if things improve.

Thanks!
Comment 3 Jason A. Whittle 2000-02-17 22:58:59 EST
I have updated to ppp-2.3.11-2.i386.rpm, rp3-1.0.7-3.i386.rpm, and wvdial-1.41-
2.i386.rpm from rawhide. No change.
Comment 4 Nalin Dahyabhai 2000-02-29 11:30:59 EST
What does "/sbin/route -n" output?  Can you run "/usr/sbin/traceroute
206.132.41.202"?  It sounds as if for some reason your default routes are not
being set, though I can't figure out why dialing up in debug mode would affect
that behavior either way....
Comment 5 Alan Cox 2002-12-13 21:02:33 EST
No answer in 2 years.Plus the new tools are way better and fixed so many bugs.

Note You need to log in before you can comment on or make changes to this bug.