Bug 824979 - No message for "subscription-manager release --list" with no subscriptions
No message for "subscription-manager release --list" with no subscriptions
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity low
: rc
: 5.9
Assigned To: William Poteat
Entitlement Bugs
:
Depends On:
Blocks: 771748 827225
  Show dependency treegraph
 
Reported: 2012-05-24 14:06 EDT by Matt Reid
Modified: 2013-01-07 22:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:52:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2012-05-24 14:06:03 EDT
Description of problem:
We should have a string to return in cases where a system is registered, but not subscribed to anything yet.

I just registered my machine, and entered "subscription-manager release --list" and got nothing back. Entering "subscription-manager release --show" returns "Release not set".

Could we show "No release versions available"? "No release versions available, please check subscriptions"?

It'd be nice if we included something to either say they have no possible release versions, or that they won't have any until they subscribe to something.
Comment 1 Alex Wood 2012-06-19 15:49:27 EDT
commit e0d71387efb6737dd157034bf36f8542c2d2f6f7
Refs: <origin/bug824979>, subscription-manager-1.0.3-1-50-ge0d7138
Author:     William Poteat <wpoteat@redhat.com>
AuthorDate: Wed Jun 13 08:36:19 2012 -0400
Commit:     William Poteat <wpoteat@redhat.com>
CommitDate: Wed Jun 13 08:36:19 2012 -0400

    824979: No message for subscription-manager release --list with no subscriptions.
Comment 2 RHEL Product and Program Management 2012-06-19 16:08:32 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Shwetha Kallesh 2012-06-21 04:43:23 EDT
Marking verified!!

RPM version:
[root@dhcp201-196 ~]# rpm -qa | grep subscription-manager
subscription-manager-gui-1.0.4-1.git.1.b28337e.el5
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
subscription-manager-migration-1.0.4-1.git.1.b28337e.el5
subscription-manager-1.0.4-1.git.1.b28337e.el5
subscription-manager-firstboot-1.0.4-1.git.1.b28337e.el5


[root@dhcp201-196 ~]# subscription-manager register
Username: stage_test_12
Password: 
The system has been registered with id: 82cfdf86-33bf-4afa-8582-156d8bc88c00 
[root@dhcp201-196 ~]# subscription-manager release --list
No release versions available, please check subscriptions.
Comment 4 Sharath Dwaral 2012-06-21 08:51:21 EDT
Version 

RHEL 5.9

# rpm -qa | grep subscription-manager
subscription-manager-migration-1.0.4-1.git.1.b28337e.el5
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
subscription-manager-firstboot-1.0.4-1.git.1.b28337e.el5
subscription-manager-1.0.4-1.git.1.b28337e.el5
subscription-manager-gui-1.0.4-1.git.1.b28337e.el5

# rpm -qa | grep python-rhsm
python-rhsm-1.0.2-1.git.2.d5c3d05.el5

Actual Result:
# subscription-manager release --show
Release not set

# subscription-manager release --list
No release versions available, please check subscriptions.

Expected Result:
As Above

>Moving Bug to Verified
Comment 6 errata-xmlrpc 2013-01-07 22:52:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.