Bug 824981 - dracut initramfs not created Rawhide\F18 x86 and x86_64
dracut initramfs not created Rawhide\F18 x86 and x86_64
Status: CLOSED DUPLICATE of bug 826689
Product: Fedora
Classification: Fedora
Component: grubby (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-24 14:10 EDT by Frank Murphy
Modified: 2012-06-06 04:38 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 12:15:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dracut --debug (6.27 MB, application/octet-stream)
2012-05-24 14:10 EDT, Frank Murphy
no flags Details
dracut --debug (6.27 MB, text/plain)
2012-05-24 14:14 EDT, Frank Murphy
no flags Details
32 bit blkid stuff (921 bytes, text/plain)
2012-05-26 04:18 EDT, Frank Murphy
no flags Details
32 bit /etc/crypttab (309 bytes, text/plain)
2012-05-26 04:18 EDT, Frank Murphy
no flags Details
32 bit dmsetup tree (326 bytes, text/plain)
2012-05-26 04:19 EDT, Frank Murphy
no flags Details
32 bit lvm stuff (2.76 KB, text/plain)
2012-05-26 04:20 EDT, Frank Murphy
no flags Details
32 bit /boot/grub2/grub.cfg (8.91 KB, text/plain)
2012-05-26 04:21 EDT, Frank Murphy
no flags Details
32 bit blkid stuff (896 bytes, text/plain)
2012-05-26 04:32 EDT, Frank Murphy
no flags Details
seriel-console capture (23.98 KB, text/plain)
2012-05-27 08:53 EDT, Frank Murphy
no flags Details
debug.log from yum update (3.52 MB, text/plain)
2012-05-29 22:11 EDT, Frank Murphy
no flags Details

  None (edit)
Description Frank Murphy 2012-05-24 14:10:29 EDT
Created attachment 586684 [details]
dracut --debug

Description of problem: No initramfs created with 3.5 kernels



Version-Release number of selected component (if applicable):
dracut-018-74.git20120522.fc18.noarch


How reproducible: the last 3 kernels, inistall\unistall dracut --force


Steps to Reproduce:
1. install dracut above
2. yum update to 3.5 kernel
3.
  
Actual results: cannot find root system


Expected results: boot


Additional info: follow on to test list thread:
https://lists.fedoraproject.org/pipermail/test/2012-May/108254.html
Comment 1 Frank Murphy 2012-05-24 14:14:40 EDT
Created attachment 586685 [details]
dracut --debug
Comment 2 Frank Murphy 2012-05-26 04:18:15 EDT
Created attachment 586997 [details]
32 bit blkid stuff
Comment 3 Frank Murphy 2012-05-26 04:18:52 EDT
Created attachment 586998 [details]
32 bit /etc/crypttab
Comment 4 Frank Murphy 2012-05-26 04:19:33 EDT
Created attachment 586999 [details]
32 bit dmsetup tree
Comment 5 Frank Murphy 2012-05-26 04:20:26 EDT
Created attachment 587000 [details]
32 bit lvm stuff
Comment 6 Frank Murphy 2012-05-26 04:21:39 EDT
Created attachment 587001 [details]
32 bit /boot/grub2/grub.cfg

Can upload the 64bit info as\when required
Comment 7 Frank Murphy 2012-05-26 04:32:03 EDT
Created attachment 587004 [details]
32 bit blkid stuff

forgot to add /dev/vda
Comment 8 Frank Murphy 2012-05-27 08:53:20 EDT
Created attachment 587075 [details]
seriel-console capture

After following a workaround on test list:
https://lists.fedoraproject.org/pipermail/test/2012-May/108318.html

rpm -e device-mapper-multipath-libs-0.4.9-22.fc18.i686(x86_64) 
device-mapper-multipath-0.4.9-22.fc18.i686(x86_64)


an initramfs was created, but still unbootable.
So something has changed in the way mulitpath is created\used.
Now also have plymouth\initqueue\crypto\systemd-udev problems,
more than likely due to removing *multipath*
Comment 9 Harald Hoyer 2012-05-29 11:02:27 EDT
(In reply to comment #6)
> Created attachment 587001 [details]
> 32 bit /boot/grub2/grub.cfg
> 
> Can upload the 64bit info as\when required

so... the initramfs entry in the grub.conf is missing.

The error could be in /usr/sbin/new-kernel-pkg, which is part of grubby
Comment 10 Harald Hoyer 2012-05-29 11:03:13 EDT
(In reply to comment #1)
> Created attachment 586685 [details]
> dracut --debug

/sbin/dracut@858(): dinfo 'Wrote /boot/initramfs-3.5.0-0.rc0.git6.1.fc18.x86_64.img:'
/usr/lib/dracut/dracut-logger.sh@343(dinfo): set +x
//sbin/dracut@859(): ls -l /boot/initramfs-3.5.0-0.rc0.git6.1.fc18.x86_64.img
/sbin/dracut@859(): dinfo '-rw-r--r--. 1 root root 17673066 May 24 18:59 /boot/initramfs-3.5.0-0.rc0.git6.1.fc18.x86_64.img'
/usr/lib/dracut/dracut-logger.sh@343(dinfo): set +x
/sbin/dracut@861(): exit 0


looks good, doesn't it?
Comment 11 Harald Hoyer 2012-05-29 11:03:55 EDT
reassigning to grubby, because of comment 9
Comment 12 Frank Murphy 2012-05-29 22:03:15 EDT
(In reply to comment #9)
> (In reply to comment #6)
> > Created attachment 587001 [details]
> > 32 bit /boot/grub2/grub.cfg
> > 
> > Can upload the 64bit info as\when required
> 
> so... the initramfs entry in the grub.conf is missing.
> 
> The error could be in /usr/sbin/new-kernel-pkg, which is part of grubby

This way due to me:
yum erase kernel\ yum install kernel\ rpm -e\-i
The /etc/grub2.cfg entries were created ok, but it was a nerwer kernel.
when /etc/grub2.cfg was uploaded.
Comment 13 Frank Murphy 2012-05-29 22:04:52 EDT
(In reply to comment #10)
> (In reply to comment #1)
> > Created attachment 586685 [details]
> > dracut --debug
> 
> /sbin/dracut@858(): dinfo 'Wrote
> /boot/initramfs-3.5.0-0.rc0.git6.1.fc18.x86_64.img:'
> /usr/lib/dracut/dracut-logger.sh@343(dinfo): set +x
> //sbin/dracut@859(): ls -l /boot/initramfs-3.5.0-0.rc0.git6.1.fc18.x86_64.img
> /sbin/dracut@859(): dinfo '-rw-r--r--. 1 root root 17673066 May 24 18:59
> /boot/initramfs-3.5.0-0.rc0.git6.1.fc18.x86_64.img'
> /usr/lib/dracut/dracut-logger.sh@343(dinfo): set +x
> /sbin/dracut@861(): exit 0
> 
> 
> looks good, doesn't it?

It does, will upload a new /var/log/dracut.log
created as part of "yum update". May help shed light for whicever team.
Comment 14 Frank Murphy 2012-05-29 22:11:14 EDT
Created attachment 587577 [details]
debug.log from yum update

This is from kernel-3.5.0-0.rc0.git8.1.fc18 
http://koji.fedoraproject.org/koji/buildinfo?buildID=320723

You will notice a failed:
"F: installkernel failed in module multipath"
Comment 15 Paul Howarth 2012-05-30 06:07:38 EDT
(In reply to comment #14)
> You will notice a failed:
> "F: installkernel failed in module multipath"

I see this just when running dracut on a Rawhide (i686) VM:

# dracut -f /boot/initramfs-3.5.0-0.rc0.git8.1.fc18.i686.PAE.img 3.5.0-0.rc0.git8.1.fc18.i686.PAE
F: installkernel failed in module multipath
# rpm -q dracut
dracut-018-74.git20120522.fc18.noarch

Curiously, if I add the --debug option, an initramfs does get built but the system won't boot anyway, the kernel complaining about a module format problem.
Comment 16 Frank Murphy 2012-06-05 12:15:03 EDT
Fixed by dracut-019-1.fc18 for me
http://koji.fedoraproject.org/koji/buildinfo?buildID=321891

*** This bug has been marked as a duplicate of bug 826689 ***
Comment 17 Paul Howarth 2012-06-06 04:38:26 EDT
Fixed by dracut-019-1.fc18 for me too.

Note You need to log in before you can comment on or make changes to this bug.