Bug 825041 - grub2 fails on F17 install when multiple distros present (os-prober)
grub2 fails on F17 install when multiple distros present (os-prober)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: os-prober (Show other bugs)
17
ppc64 All
unspecified Severity high
: ---
: ---
Assigned To: Hedayat Vatankhah
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-24 18:00 EDT by IBM Bug Proxy
Modified: 2012-06-10 20:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-02 19:56:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
original grub.cfg.new file created by current os-prober (7.07 KB, application/octet-stream)
2012-05-24 18:00 EDT, IBM Bug Proxy
no flags Details
40yaboot patch 1 (503 bytes, text/plain)
2012-05-24 18:01 EDT, IBM Bug Proxy
no flags Details
40yaboot patch 2 (892 bytes, application/octet-stream)
2012-05-24 18:01 EDT, IBM Bug Proxy
no flags Details
anaconda program log (71.00 KB, text/x-log)
2012-05-24 18:01 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 81900 None None None Never
Debian BTS 674561 None None None Never

  None (edit)
Description IBM Bug Proxy 2012-05-24 18:00:38 EDT
Problem Description:

When you install F17, if you have multiple distros present other disks, the grub2-mkconfig will fail and leave you with an unbootable system.  It will create the grub.cfg.new file, but because it fails a syntax check, it will not rename it and allow grub to boot/configure properly.  Will attach relevant log files and such
 
As you can see, one of the key problems in that grub.cfg.new is in line 149.  It's apparent that the files in os-prober do not process the yaboot.conf file properly when the append is followed by a space and = sign.  Example:

append = "some params"
append="some params"

Both are acceptable to yaboot itself, but the /usr/libexec/linux-boot-probes/mounted/40yaboot script does not account for that.

We have attached two proposed patches for your consideration.
Comment 1 IBM Bug Proxy 2012-05-24 18:00:53 EDT
Created attachment 586717 [details]
original grub.cfg.new file created by current os-prober
Comment 2 IBM Bug Proxy 2012-05-24 18:01:07 EDT
Created attachment 586718 [details]
40yaboot patch 1
Comment 3 IBM Bug Proxy 2012-05-24 18:01:19 EDT
Created attachment 586719 [details]
40yaboot patch 2
Comment 4 IBM Bug Proxy 2012-05-24 18:01:32 EDT
Created attachment 586720 [details]
anaconda program log
Comment 5 Hedayat Vatankhah 2012-05-25 06:47:40 EDT
Thank you for reporting the problem and providing the patches. I think I'll go with the first patch, but I'll forward both to upstream.
Comment 6 Hedayat Vatankhah 2012-05-25 07:22:40 EDT
Hmm.. but I think there is no need to change case "$1" with case "${1%%=*}" since bash already do it (considering the IFS variable). Right?
Comment 7 Fedora Update System 2012-05-25 08:53:51 EDT
os-prober-1.53-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/os-prober-1.53-2.fc16
Comment 8 Fedora Update System 2012-05-25 08:54:07 EDT
os-prober-1.53-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/os-prober-1.53-2.fc17
Comment 9 IBM Bug Proxy 2012-05-25 09:00:59 EDT
------- Comment From baude@us.ibm.com 2012-05-25 12:55 EDT-------
I'll defer to you and others on that one. Please roll a new src rpm and let us know as this currently blocks ppc64 F17 RC.
Comment 10 Hedayat Vatankhah 2012-05-25 09:20:03 EDT
You can find the src.rpm at: http://koji.fedoraproject.org/koji/buildinfo?buildID=320525
Comment 11 IBM Bug Proxy 2012-05-25 10:01:40 EDT
------- Comment From baude@us.ibm.com 2012-05-25 13:54 EDT-------
I've tested the new package locally and it seems to fix the problem we are seeing.  The real test will be to get our IS rebuilt with the new package.
Comment 12 IBM Bug Proxy 2012-05-25 10:31:17 EDT
------- Comment From baude@us.ibm.com 2012-05-25 14:29 EDT-------
Is there any chance you could join us on freenode on #fedora-ppc?  I have some follow-up questions.
Comment 13 Fedora Update System 2012-05-26 04:07:10 EDT
Package os-prober-1.53-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing os-prober-1.53-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8433/os-prober-1.53-2.fc17
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2012-06-02 12:54:19 EDT
os-prober-1.53-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/os-prober-1.53-3.fc16
Comment 15 Fedora Update System 2012-06-02 12:55:45 EDT
os-prober-1.53-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/os-prober-1.53-3.fc17
Comment 16 Fedora Update System 2012-06-02 19:56:38 EDT
os-prober-1.53-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2012-06-08 20:03:13 EDT
os-prober-1.53-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2012-06-10 20:00:06 EDT
os-prober-1.53-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.