Bug 825055 - Docky that crashes on clean install of Fedora 16 with latest updates
Docky that crashes on clean install of Fedora 16 with latest updates
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: docky (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukas Zapletal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-24 19:16 EDT by Naipaul Ojar
Modified: 2012-05-25 10:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-25 09:58:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Naipaul Ojar 2012-05-24 19:16:32 EDT
Description of problem:
New installation of Docky a clean Fedora 16 with patches crashes when:-
a. The configuration tick-box to set "Start when computer starts"
b. When either of the other two tabs is selected.

I have Docky running on my other Fedora 16 installation which has been installed since Feb, 2012 and has been updated weekly.

I re-installed Fedora 16 using the same DVD image and then performed a yum update, I have selected Development model

Version-Release number of selected component (if applicable):
Docky that crashes and exits

How reproducible:
When ever Docky is started

Steps to Reproduce:
1. Clean install of Fedora 16 based on Feb 2012 download
2. Perform yum update - 928 updates
3. Install docky and its dependancies
4. Start Docky
5. Enter its configuration menu
6. Either tick the "start when Computer starts" or Select one of the two other tabs - docklets
7. Docky exits

  
Actual results:
 ~]$ docky
[Info  23:48:25.303] Docky version: 2.0.12 Release
[Info  23:48:25.308] Kernel version: 3.3.6.3
[Info  23:48:25.309] CLR version: 2.0.50727.1433
[Info  23:48:25.570] [DockServices] Dock services initialized.
[Info  23:48:25.689] [DockController] Setting theme: Classic
[Info  23:48:25.878] [PluginManager] Loaded "Trash".
[Info  23:48:27.596] [HelperService] Helper added: /usr/share/docky/helpers/banshee_control.py
[Info  23:48:27.596] [HelperService] Helper added: /usr/share/docky/helpers/banshee_control.pyc
[Info  23:48:27.596] [HelperService] Helper added: /usr/share/docky/helpers/banshee_control.pyo
[Info  23:48:27.596] [HelperService] Helper added: /usr/share/docky/helpers/deluge_badge.py
[Info  23:48:27.596] [HelperService] Helper added: /usr/share/docky/helpers/deluge_badge.pyc
[Info  23:48:27.597] [HelperService] Helper added: /usr/share/docky/helpers/deluge_badge.pyo
[Info  23:48:27.597] [HelperService] Helper added: /usr/share/docky/helpers/gajim_badge.py
[Info  23:48:27.597] [HelperService] Helper added: /usr/share/docky/helpers/gajim_badge.pyc
[Info  23:48:27.597] [HelperService] Helper added: /usr/share/docky/helpers/gajim_badge.pyo
[Info  23:48:27.597] [HelperService] Helper added: /usr/share/docky/helpers/gtg_menus.py
[Info  23:48:27.597] [HelperService] Helper added: /usr/share/docky/helpers/gtg_menus.pyc
[Info  23:48:27.597] [HelperService] Helper added: /usr/share/docky/helpers/gtg_menus.pyo
[Info  23:48:27.597] [HelperService] Helper added: /usr/share/docky/helpers/liferea_badge.py
[Info  23:48:27.597] [HelperService] Helper added: /usr/share/docky/helpers/liferea_badge.pyc
[Info  23:48:27.598] [HelperService] Helper added: /usr/share/docky/helpers/liferea_badge.pyo
[Info  23:48:27.598] [HelperService] Helper added: /usr/share/docky/helpers/open_terminal_here.py
[Info  23:48:27.598] [HelperService] Helper added: /usr/share/docky/helpers/open_terminal_here.pyc
[Info  23:48:27.598] [HelperService] Helper added: /usr/share/docky/helpers/open_terminal_here.pyo
[Info  23:48:27.598] [HelperService] Helper added: /usr/share/docky/helpers/pidgin_control.py
[Info  23:48:27.598] [HelperService] Helper added: /usr/share/docky/helpers/pidgin_control.pyc
[Info  23:48:27.598] [HelperService] Helper added: /usr/share/docky/helpers/pidgin_control.pyo
[Info  23:48:27.598] [HelperService] Helper added: /usr/share/docky/helpers/rhythmbox_control.py
[Info  23:48:27.598] [HelperService] Helper added: /usr/share/docky/helpers/rhythmbox_control.pyc
[Info  23:48:27.599] [HelperService] Helper added: /usr/share/docky/helpers/rhythmbox_control.pyo
[Info  23:48:27.599] [HelperService] Helper added: /usr/share/docky/helpers/tomboy_menus.py
[Info  23:48:27.599] [HelperService] Helper added: /usr/share/docky/helpers/tomboy_menus.pyc
[Info  23:48:27.599] [HelperService] Helper added: /usr/share/docky/helpers/tomboy_menus.pyo
[Info  23:48:27.599] [HelperService] Helper added: /usr/share/docky/helpers/zeitgeist_docky.py
[Info  23:48:27.599] [HelperService] Helper added: /usr/share/docky/helpers/zeitgeist_docky.pyc
[Info  23:48:27.599] [HelperService] Helper added: /usr/share/docky/helpers/zeitgeist_docky.pyo
[Info  23:48:27.599] [HelperService] Helper added: /usr/share/docky/helpers/zeitgeist_journal.py
[Info  23:48:27.599] [HelperService] Helper added: /usr/share/docky/helpers/zeitgeist_journal.pyc
[Info  23:48:27.600] [HelperService] Helper added: /usr/share/docky/helpers/zeitgeist_journal.pyo
[Info  23:48:27.610] [DrawingService] Could not find 'banshee', using fallback of 'extension'.
[Info  23:48:27.613] [DrawingService] Could not find 'deluge', using fallback of 'extension'.
[Info  23:48:27.616] [DrawingService] Could not find 'gajim', using fallback of 'extension'.
[Info  23:48:27.620] [DrawingService] Could not find 'gtg', using fallback of 'extension'.
[Info  23:48:27.623] [DrawingService] Could not find 'liferea', using fallback of 'extension'.
[Info  23:48:27.628] [DrawingService] Could not find 'pidgin', using fallback of 'extension'.
[Info  23:48:27.632] [DrawingService] Could not find 'rhythmbox', using fallback of 'extension'.
[Info  23:48:27.635] [DrawingService] Could not find 'tomboy', using fallback of 'extension'.
[Info  23:48:32.928] [PluginManager] Loaded "Docky.Widgets,1.0".
[Error 23:48:33.008] [AbstractDockItem] An exception was thrown by the type initializer for Docky.ConfigurationWindow
Marshaling toggled signal
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.TypeInitializationException: An exception was thrown by the type initializer for Docky.ConfigurationWindow ---> System.DllNotFoundException: libgnome-desktop-2.so.17
  at (wrapper managed-to-native) Gnome.DesktopItem:gnome_desktop_item_new_from_file (intptr,int,intptr&)
  at Gnome.DesktopItem.NewFromFile (System.String file, DesktopItemLoadFlags flags) [0x00000] in <filename unknown>:0 
  at Docky.ConfigurationWindow.get_AutoStart () [0x00000] in <filename unknown>:0 
  at Docky.ConfigurationWindow..ctor () [0x00000] in <filename unknown>:0 
  at Docky.ConfigurationWindow..cctor () [0x00000] in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at Docky.Items.DockyItem.OnClicked (UInt32 button, ModifierType mod, Double xPercent, Double yPercent) [0x00000] in <filename unknown>:0 
  at Docky.Items.AbstractDockItem.Clicked (UInt32 button, ModifierType mod, Double xPercent, Double yPercent) [0x00000] in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0 
  at System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) [0x00000] in <filename unknown>:0 
  at System.Delegate.DynamicInvokeImpl (System.Object[] args) [0x00000] in <filename unknown>:0 
  at System.MulticastDelegate.DynamicInvokeImpl (System.Object[] args) [0x00000] in <filename unknown>:0 
  at System.Delegate.DynamicInvoke (System.Object[] args) [0x00000] in <filename unknown>:0 
  at GLib.Signal.ClosureInvokedCB (System.Object o, GLib.ClosureInvokedArgs args) [0x00000] in <filename unknown>:0 
  at GLib.SignalClosure.Invoke (GLib.ClosureInvokedArgs args) [0x00000] in <filename unknown>:0 
  at GLib.SignalClosure.MarshalCallback (IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data) [0x00000] in <filename unknown>:0 
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at GLib.SignalClosure.MarshalCallback(IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data)
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Docky.Docky.Main(System.String[] args)
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose

Unhandled Exception: System.TypeInitializationException: An exception was thrown by the type initializer for Docky.ConfigurationWindow ---> System.DllNotFoundException: libgnome-desktop-2.so.17
  at (wrapper managed-to-native) Gnome.DesktopItem:gnome_desktop_item_new_from_file (intptr,int,intptr&)
  at Gnome.DesktopItem.NewFromFile (System.String file, DesktopItemLoadFlags flags) [0x00000] in <filename unknown>:0 
  at Docky.ConfigurationWindow.get_AutoStart () [0x00000] in <filename unknown>:0 
  at Docky.ConfigurationWindow..ctor () [0x00000] in <filename unknown>:0 
  at Docky.ConfigurationWindow..cctor () [0x00000] in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at Docky.Items.DockyItem.OnClicked (UInt32 button, ModifierType mod, Double xPercent, Double yPercent) [0x00000] in <filename unknown>:0 
  at Docky.Items.AbstractDockItem.Clicked (UInt32 button, ModifierType mod, Double xPercent, Double yPercent) [0x00000] in <filename unknown>:0 
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: An exception was thrown by the type initializer for Docky.ConfigurationWindow ---> System.DllNotFoundException: libgnome-desktop-2.so.17
  at (wrapper managed-to-native) Gnome.DesktopItem:gnome_desktop_item_new_from_file (intptr,int,intptr&)
  at Gnome.DesktopItem.NewFromFile (System.String file, DesktopItemLoadFlags flags) [0x00000] in <filename unknown>:0 
  at Docky.ConfigurationWindow.get_AutoStart () [0x00000] in <filename unknown>:0 
  at Docky.ConfigurationWindow..ctor () [0x00000] in <filename unknown>:0 
  at Docky.ConfigurationWindow..cctor () [0x00000] in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at Docky.Items.DockyItem.OnClicked (UInt32 button, ModifierType mod, Double xPercent, Double yPercent) [0x00000] in <filename unknown>:0 
  at Docky.Items.AbstractDockItem.Clicked (UInt32 button, ModifierType mod, Double xPercent, Double yPercent) [0x00000] in <filename unknown>:0 


Expected results:
1. Tick-box to be ticked or tab to be selected.

Additional info:

1. I have other issues with Fedora 16 with Gnome dying at random times when VMWare is running, and I decided to build a new Fedora 16 image to migrate the data off the old image. I tested F17, but too many issues at this time
2. Docky is the 2nd application installed on the base F16. The first application is gnome-tweak-tool
3. The same version of Docky is working on my other F16 image, that image was created in Feb, 2012
4. I do not have th checksum of the image, I do have the DVD of the full Fedora 16 deployment
Comment 1 Naipaul Ojar 2012-05-24 19:26:34 EDT
I have just seen the error:-

System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.TypeInitializationException: An exception was thrown by the type initializer for Docky.ConfigurationWindow ---> System.DllNotFoundException: libgnome-desktop-2.so.17

I took the opportunity to install:-
yum install gnome-desktop
  - Something that I have done on my other deployment

Now that I have installed gnome-desktop, Docky is working.

Now Docky does not crash and I can do the following:-
a. Set the "start when computer starts"
b. Select the Docklets tab and select Docklets

From that test, it seems that the package "gnome-desktop" is currently an undefined dependancy for Docky under Gnome desktop

When Docky was being installed, about 12 other dependancies were installed.

Either gnome-desktop should be a default base package or it should be a dependancy of the Docky package.
Comment 2 Lukas Zapletal 2012-05-25 09:58:12 EDT
This will be fixed in the next docky update.
Comment 3 Naipaul Ojar 2012-05-25 10:05:59 EDT
Dear Support team,

Thanks for the update.

I found a similar experience when testing on the Beta F17 download, only on that test Docky would not start. This bug has already been reported.

Could the two bugs be linked ? (I am unable to test this because I rebuilt my test machine for a clean F16 rebuild and test).

If I can assist, pls request and I can attempt to assist.

Thanks in advance.
Comment 4 Naipaul Ojar 2012-05-25 10:13:04 EDT
Is there any comments available on why some of the Docklets do not work in this version :-
 - Weather, NPR, Network

There are some comments that these do not also work on Ubuntu. The Docky site states that Fedora is not a supported platform, but I built Docky from source on Fedora 13 and all components worked fine - different version of Docky though.

Note You need to log in before you can comment on or make changes to this bug.