Bug 82508 - don't start FreeWnn by default on systems that don't need it
don't start FreeWnn by default on systems that don't need it
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: comps (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
Brock Organ
:
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2003-01-22 17:19 EST by Thomas M Steenholdt
Modified: 2007-04-18 12:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-30 14:34:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas M Steenholdt 2003-01-22 17:19:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

Description of problem:
Based on system locale or something similar, FreeWnn should be enabled or
disabled, so that it's not running on system that will never need it...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Phoebe .93
2. Select Danish kb and English(Denmark) locale
3. Watch as FreeWnn is started on boot (after install)

Actual Results:  it is starting

Expected Results:  it should not be starting

Additional info:
Comment 1 Nakai 2003-01-23 04:22:31 EST
FreeWnn will be installed when you choose 'Japanese' with at install.
If you don't want FreeWnn installed, you should not choose 'Japanese' or
'All languages' at that time.
Comment 2 Thomas M Steenholdt 2003-01-23 05:36:17 EST
Please read the report, it's 5 lines of text stating...

Selecting dk keyboard (nothing else)
Selecting English/Denmark) locale (nothing else)

Although this is a full install using custom, everything this is still bad!

I want to have all packages installed, but have absolutely no use for FreeWnn as
my japanese is really bad :)

-Or please explain it to me more carefully!
Comment 3 Nakai 2003-01-24 02:25:19 EST
Sorry this is really a bug.

FreeWnn should not be installed when only English/Denmark locale.
Reassign to anaconda team.
Comment 4 Michael Fulbright 2003-01-27 12:01:34 EST
Sorry to pass this on, but this is a comps issue.

Anaconda only installs what comps tells us to.

Comment 5 Tim Powers 2003-01-30 14:34:58 EST
This is not a bug. If you install everything, you get everything, and FreeWnn is
turned on by default. The reason for this is that we have no way of knowing for
sure that none of the users will have their default language set to Japanese,
for example.

Closing as not a bug.
Comment 6 Thomas M Steenholdt 2003-01-30 14:48:16 EST
If you ask me, you can be pretty darn sure, that the language every user, who
installs everything, want, is the language he selects during installation?!!
If this cannot easily be acomplished (i'm not sure how anaconda works
internally) but couldn't it be possible to set up env vars, hinting at the
language etc selected during installation, and then check against those
variables when installing the FreeWnn rpm... perhaps an even better method(in
terms of genericness) could be to have a module running at the end of the
installation, where packages selected during installation can modify basic
settings according to user input?

Of course these are just suggestions, I can perfectly well see your point in
that an rpm being installed, will have problems, from some of the scripts to
determine exactly the language the user wants. Its just a little sad!

Well, there you have my 5 cents on the issue - Thanks for taking a look at the
rapport
Comment 7 Tim Powers 2003-01-30 15:05:50 EST
On a home system, sure, I'll agree with that. If the machine happens to be used
by multiple people you can't be certain that when the user logs in that they
don't use a different language. 

I've seen even seen this here at Red Hat. During the installation en_US was
selected, but the user actualy used a Norwegian environment. It's not uncommon
to see this.

Tim
Comment 8 Eido Inoue 2003-01-30 16:20:44 EST
FreeWnn is a server that listens on a TCP/IP port. There are some (granted few)
environments where a central FreeWnn server will serve remote clients (usually
for the purpose of sharing a custom dictionary). Thus, the Japanese FreeWnn user
doesn't even have to run X clients on the said local machine to use the Wnn
server. IOW, FreeWnn is sometimes needed even when Japanese users never
telnet/ssh into the server.
Comment 9 Thomas M Steenholdt 2003-01-30 18:21:02 EST
Usually, though, defaults are for the majority of people... It's that way
because it pushes fewer people into reconfiguration, which in turn means that
more people will have a smoother experience with the product!

If you can't or won't do this, just say so... I guess i can live with having to
tweak the system a bit after installation... It's just too bad that newbies will
not get max performance out of their systems because several unrequired daemons
are started.
Comment 10 Tim Powers 2003-01-30 20:00:52 EST
You're missing the point completely. You are thinking from a sungle-user
perspective and not considering that there are many installs which are used by
multiple people who speak different languages, and it should work for them.

No, this isn't going to change (at least for this release).
Comment 11 Thomas M Steenholdt 2003-01-31 00:45:06 EST
I'm not mising the point at all - What I posted here are merely a suggestion,
that maybe, if something COULD be done about this, it SHOULD.

Since comment #5 I have been convinced that this is in fact not a bug. I have
just been pointing out some things to MAYBE keep in mind in the case you ever
wanted to change some bacics of the installation process.

Summary of oppinons: It would be nice if everybody, would come up with a system
only running what is required by that user, after installation. (usually large
scale install roll-outs will be customizing all kinds of stuff so these guys we
can really gain that much from pleasing in this respect, i think)

I know this is not easy - but that doesn't mean that you should not think about
in case of installer restructuring or, whatever...

Hope this cleared things up a bit. I'm not trying to nag - I'm pushing a couple
of suggestions thats it. Sorry for any misunderstanding
Comment 12 Eido Inoue 2003-01-31 01:49:00 EST
thanks for the suggestion. you should also be aware that "installing everything"
is not what most users do, and we do not encourage most users to select this--
which is why the option is kind of buried in the installer. that's intentional.

so to address comment #9, "defaults are for the majority of people", this is
exactly what we do-- we do not default nor encourage users to "install
everything", nor do we default to installing FreeWnn.

As for your comment re large-scale rollouts, customizations such as "everything
except for a certain package" (such as FreeWnn) is possible with kickstart.

Finally, as for the "if you can't or won't do this, just say so" comment, the
status of this bug is "CLOSED NOTABUG", which implies "WONTFIX". Thanks for your
suggestion though.
Comment 13 Nakai 2003-01-31 02:42:19 EST
Let me review the point-:

FreeWnn is the Japanese only package, is an important one for Japanese
speakers, but is also a waste of machine resource for who don't speak Japanese.

And there is a requirement:

1. FreeWnn should not be installed when only Denmark locale is selected at
installation
2. FreeWnn should be installed when Japanese locale is selected at installation
3. FreeWnn will be installed automatically when the user choose 'everything'

2 and 3 are ok, but 1 is not satisfied yet.
This is the point of this bug report,right?
Comment 14 Nakai 2003-01-31 03:11:39 EST
Hmm, I understand this issue happens because the lang selection is not prior
to 'everything' at install.

Comment 15 Thomas M Steenholdt 2003-01-31 06:50:43 EST
Actually, i don't know what happens if i don't install everything, because i
tend to always do that(for my workstation installations)...

to answer comment #13
i guess it all works like you have outlined here, an it's fine with me as long
as i understand why it happens. [Everything] means each and every package on the
installation media! This is also what i expected before i generated this report...

But to dig in just a little further, and it looks like ynakai is thinking about
something, comment #14 (maybe???), when i select that i want to use
"English(Denmark)" locale - that locale is the effectivated one - even though
others are installed. Why couldn't something similar be done with FreeWnn? what
i mean is, go ahead and install the package, i asked for it, but selecting to
install everything doesn't mean that i want all services started automatically...
Comment 16 Thomas M Steenholdt 2003-01-31 06:56:07 EST
btw, guys, if this discussion is of no use to you, let's just leave it at this.
the annoyance is less than minor to me and i can easily accept the explaination
i got a long time ago in this report.
on the other hand, if you feel like pursuing this, i'll be more than happy to
continue my participation in this discussion!

Note You need to log in before you can comment on or make changes to this bug.