Bug 825087 - RFE: Handle '~' in version/release to lower priority in rpmVersionCompare()
RFE: Handle '~' in version/release to lower priority in rpmVersionCompare()
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rpm (Show other bugs)
6.3
Unspecified Linux
high Severity medium
: rc
: ---
Assigned To: Panu Matilainen
Patrik Kis
: FutureFeature
Depends On: 734802
Blocks: 843460
  Show dependency treegraph
 
Reported: 2012-05-25 01:19 EDT by Panu Matilainen
Modified: 2013-02-21 05:51 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 734802
Environment:
Last Closed: 2013-02-21 05:51:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Panu Matilainen 2012-05-25 01:19:01 EDT
+++ This bug was initially created as a clone of Bug #734802 +++

This seems like a nice to have feature, so I wanted to forward it from rpm.org's trac (currently read-only):

From <http://rpm.org/ticket/56>:
,---
It would be nice when a special handling of '~' would be introduced to mark "negative" version tokens. E.g. so that

| foo-1.0~beta < foo-1.0

holds. This would simplify complicated rulesets which deal with such naming schemes by abusing %release for it. 
`---
Comment 1 Panu Matilainen 2012-05-25 01:20:55 EDT
Cloned for RHEL-6 as the koji builders need to support this before the feature can be used in Fedora (and eventually RHEL-7)
Comment 4 RHEL Product and Program Management 2012-07-10 04:10:30 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-07-10 21:52:02 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 15 errata-xmlrpc 2013-02-21 05:51:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0461.html

Note You need to log in before you can comment on or make changes to this bug.