Bug 825092 - Fedora 17 DVD upgrade delivers an unusable system
Fedora 17 DVD upgrade delivers an unusable system
Status: CLOSED DUPLICATE of bug 820351
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 01:47 EDT by Panos Kavalagios
Modified: 2013-01-10 01:47 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-25 15:21:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Old F16 kernel is loaded after upgrade (24.63 KB, image/png)
2012-05-25 01:49 EDT, Panos Kavalagios
no flags Details
Plymouth text graphics still advertise Fedora 16 (23.30 KB, image/png)
2012-05-25 01:50 EDT, Panos Kavalagios
no flags Details
The system hangs at this screen when boot is over (36.77 KB, image/png)
2012-05-25 01:52 EDT, Panos Kavalagios
no flags Details
Shutdown or reboot cause a kernel panic (36.26 KB, image/png)
2012-05-25 01:53 EDT, Panos Kavalagios
no flags Details
Contents of /var/log/anaconda (42.95 KB, application/zip)
2012-05-25 02:11 EDT, Panos Kavalagios
no flags Details

  None (edit)
Description Panos Kavalagios 2012-05-25 01:47:41 EDT
Description of problem: Multiple problems have been identified after a successfully DVD upgrade of Fedora 16 to Fedora 17 using Fedora 17 Beta DVD installation media Fedora-17-Beta-i386-DVD.iso.


Version-Release number of selected component (if applicable): anaconda F17 beta


How reproducible: Upgrade your Fedora 16 with the DVD option


Steps to Reproduce:
1. DVD boots OK and it selects to upgrade you F16
2. After installation is over, you are prompted to reboot
3. Press the reboot button
  
Actual results: The new system boots the old F16 kernel (fedora17-dvd-upgrade-kernel.png), the booting process when stopped (fedora17-dvd-upgrade-startup.png) it does not provide you any way to log in. No graphical KDM is available (OK for that you need guest additions probably), but neither text login propmpt. Pressing Alt-F2 does not switch to any virtual console.


Expected results: You should be able to log in to the system at least in a text console.


Additional info: If you try to issue a shutdown signal or a ctrl-alt-del sequence, the upgraded system produces a kernel panic (fedora17-dvd-upgrade-panic.png). Plymouth text graphics continue to advertise the system as Fedora 16 (fedora17-dvd-upgrade-plymouth.png).
Comment 1 Panos Kavalagios 2012-05-25 01:49:25 EDT
Created attachment 586759 [details]
Old F16 kernel is loaded after upgrade
Comment 2 Panos Kavalagios 2012-05-25 01:50:47 EDT
Created attachment 586760 [details]
Plymouth text graphics still advertise Fedora 16
Comment 3 Panos Kavalagios 2012-05-25 01:52:31 EDT
Created attachment 586761 [details]
The system hangs at this screen when boot is over

There is no way to log in to the system. Neither graphical nor text. The login prompt is vanished.
Comment 4 Panos Kavalagios 2012-05-25 01:53:57 EDT
Created attachment 586762 [details]
Shutdown or reboot cause a kernel panic

A three-finger salutation (ctrl-alt-del) or shutdown signal causes the system to emit a kernel exception.
Comment 5 Panos Kavalagios 2012-05-25 02:11:57 EDT
Created attachment 586764 [details]
Contents of /var/log/anaconda

Hopefully, I was able to boot in single user mode. In the attached zip archive anaconda.zip you may find /var/log/anaconda logs for further investigation. I haven't noticed any problem in the logs and the only weird things is that the system reports no F17 PAE kernel installed (rpm -qa). Either F17 is shipped with no kernel (unlikely scenario :)) or anaconda didn't force a kernel upgrade.
Comment 6 Jesse Keating 2012-05-25 15:21:20 EDT

*** This bug has been marked as a duplicate of bug 820351 ***

Note You need to log in before you can comment on or make changes to this bug.