This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 825104 - Glyphs of NGA and NYA with vowel signs in Lohit Kannada font are improperly formed
Glyphs of NGA and NYA with vowel signs in Lohit Kannada font are improperly f...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lohit-kannada-fonts (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 02:51 EDT by Shriramana Sharma
Modified: 2012-08-27 19:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-13 04:08:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Replacement glyphs for NGA and NYA with vowel signs (16.46 KB, application/x-font-ttf)
2012-05-25 13:10 EDT, Shriramana Sharma
no flags Details
screenshot of nya-nga-matra conjucts in other fonts (47.63 KB, image/png)
2012-05-31 05:06 EDT, Pravin Satpute
no flags Details

  None (edit)
Description Shriramana Sharma 2012-05-25 02:51:16 EDT
Description of problem:

ಙಾ ಙೆ ಙೇ ಙೈ ಙೊ ಙೋ ಙೌ ಙ್
ಞಾ ಞೆ ಞೇ ಞೈ ಞೊ ಞೋ ಞೌ ಞ್

The glyphs in Lohit Kannada font representing the above sequences are improperly formed. The glyphs of -AA (NGAA and NYAA) are disjointed, and all others are awkwardly joined. In the glyphs of -O and -OO one part of the vowel sign (to the right) is disjointed and another part (to the top) is awkwardly joined. By "awkwardly joined" I mean that the cursive joining is not smooth and in fact there are un-smoothly overlapping contours within the glyph. This should be fixed to improve the quality of the fonts.

Version-Release number of selected component (if applicable):

2.5.1

How reproducible:

Input the above text in a wordprocessor using Lohit Kannada font.

Actual results:

The glyphs are disjointed or awkwardly joined.

Expected results:

The glyphs should all be smoothly joined.

Additional info:

The corresponding glyphs for all other consonants seem (so far) to be looking OK. It is only NGA and NYA which are neglected. Perhaps it is thought that they will not be used with vowel signs. While such words in Kannada language are rare, Sanskrit language and Tulu language texts are also widely written in Kannada script and those languages contains words (such as ಮಾ ತೇ ಸಙ್ಗೋಽಸ್ತ್ವಕರ್ಮಣಿ Gita 2-47) where NGA and NYA are widely used and would be needed to joined to vowel signs. So the glyphs should be given appropriate attention.
Comment 1 Shriramana Sharma 2012-05-25 13:10:51 EDT
Created attachment 586905 [details]
Replacement glyphs for NGA and NYA with vowel signs

Hello Pravin. So I sat down and did some glyph hacking myself and have arrived at a satisfactory (even if I say so myself) set of glyphs for replacing the existing disjoint/malformed glyphs in the Lohit Kannada font for the consonants NGA and NYA. Please find them in the attached TTF. I hope they are acceptable for replacing the existing glyphs. Thank you.
Comment 2 Pravin Satpute 2012-05-31 05:06:18 EDT
Created attachment 587991 [details]
screenshot of nya-nga-matra conjucts in other fonts

Yeah, rightly said, this looks like neglected combinations from long time. cursive attachments are not smoothly done.

@Shankar, we do not have these combinations in UTRRS as well.

Do we have any reference for how it should connect exactly. I gone through some  fonts they all are showing different outcome. see screenshot attached.
(sakalbharati is not opensource, it is release by DIT).

Your designed shapes looks nice to me as well thanks for it, will be nice if can get some references as well.

I think with this way we can request other fonts also to see Lohit as a reference and modify these shapes.
Comment 3 Pravin Satpute 2012-06-01 02:07:13 EDT
@Shankar  can you find some reference images for these sequence?
Comment 4 Shriramana Sharma 2012-06-01 11:08:26 EDT
Dear Pravin, I think even in academic books the people who were typesetting did not care too much about providing individual glyphs for these very rare forms. See http://std.dkuug.dk/jtc1/sc2/wg2/docs/n2860.pdf p 2. So you might not get any references (by which I think you mean attestations). At the same time, I will get approval from Kannada scholars that my designed glyphs are appropriate and forward it to lohit-devel list. 

BTW NYU NYUU are also missing and not correctly rendering. Note that you have not given C + VS-U/UU precomposed glyph for *any* consonant, but for all other consonants, just by displaying the sequence of glyphs it is sufficient. In case of NYA it is not sufficient. I will add glyphs for that also and submit later. Please give me some time.
Comment 5 Fedora Update System 2012-06-12 06:43:04 EDT
lohit-kannada-fonts-2.5.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/lohit-kannada-fonts-2.5.1-2.fc17
Comment 6 Fedora Update System 2012-06-12 06:55:20 EDT
lohit-kannada-fonts-2.5.1-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/lohit-kannada-fonts-2.5.1-2.fc16
Comment 7 Pravin Satpute 2012-06-12 06:59:18 EDT
It is clear that earlier shapes were not connecting properly. So i have added enhanced shapes from you. 

Once you done with other enhancements either submit on this bug or open new one.
Comment 8 Shriramana Sharma 2012-06-12 08:26:01 EDT
Hello I realized that for comparison of how the Kannada NGA NYA shapes should look, we can consult Telugu fonts. Even if you look at Lohit Telugu font or better GPL-ed Pothana font (which is much more stylistic and comprehensive) you can find out that it is correct to join the vowel sign to the "ponytail" curve on the top right of the consonant ಙ or ಞ.

As for my previous remark about NYA not connecting properly with VS-U and -UU, please see bug #827516 which is more comprehensive regarding -U and -UU with all Kannada consonants and also has appropriate PDFs. I will move my remarks there and we can handle that issue under that report.

Since you have fixed the rest of the NGA/NYA related glyphs except for -U/-UU, I am OK with closing this report if you are done with pushing it to the repo.
Comment 9 Pravin Satpute 2012-06-13 04:08:14 EDT
yes, let me close this. we can work on another one.
Comment 10 Fedora Update System 2012-08-27 18:54:39 EDT
lohit-kannada-fonts-2.5.1-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-08-27 19:00:01 EDT
lohit-kannada-fonts-2.5.1-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.