Bug 825122 - tg3: WARNING: at net/sched/sch_generic.c:256 dev_watchdog+0x1d7/0x1e0()
tg3: WARNING: at net/sched/sch_generic.c:256 dev_watchdog+0x1d7/0x1e0()
Status: CLOSED DUPLICATE of bug 825123
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 03:53 EDT by Christian Kujau
Modified: 2012-05-25 09:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-25 09:13:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Kujau 2012-05-25 03:53:44 EDT
Description of problem:

When the NIC (Broadcom BCM5906M, in an Lenovo Ideapad S10) is somewhat loaded, after a while the WARNING below appears and the interface is not usable any more. "ifconfig p2p1 down" and "up" again does not help, but unloading and reloading the "tg3" driver did the trick so far.
 
------------[ cut here ]------------
WARNING: at net/sched/sch_generic.c:256 dev_watchdog+0x1d7/0x1e0()
Hardware name: Lenovo          
NETDEV WATCHDOG: p2p1 (tg3): transmit queue 0 timed out
Modules linked in: nfs nfs_acl auth_rpcgss fscache lockd sunrpc ipt_MASQUERADE nf_conntrack_netbios_ns nf_conntrack_broadcast ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables iptable_nat
nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack sha256_generic dm_crypt arc4 b43 bcma mac80211 cfg80211 microcode ideapad_laptop sparse_keymap rfkill ssb tg3 mmc_core uinput wmi usb_storage i915 video i2c_algo_bit drm_kms_helper drm i2c_core [last unloaded: scsi_wait_scan]


Pid: 0, comm: swapper/0 Not tainted 3.3.4-5.fc17.i686 #1
Call Trace:
 [<c04372f2>] warn_slowpath_common+0x72/0xa0
 [<c0852077>] ? dev_watchdog+0x1d7/0x1e0
 [<c0852077>] ? dev_watchdog+0x1d7/0x1e0
 [<c04373c3>] warn_slowpath_fmt+0x33/0x40
 [<c0852077>] dev_watchdog+0x1d7/0x1e0
 [<c0851ea0>] ? dev_deactivate_queue.constprop.32+0x60/0x60
 [<c0444df1>] run_timer_softirq+0xf1/0x2a0
 [<c0851ea0>] ? dev_deactivate_queue.constprop.32+0x60/0x60
 [<c043dd77>] __do_softirq+0x97/0x190
 [<c043dce0>] ? remote_softirq_receive+0x40/0x40
 [<c043dce0>] ? remote_softirq_receive+0x40/0x40
 <IRQ>  [<c043e0bd>] ? irq_exit+0x9d/0xb0
 [<c040508b>] ? do_IRQ+0x4b/0xc0
 [<c092b833>] ? notifier_call_chain+0x43/0x60
 [<c092f470>] ? common_interrupt+0x30/0x38
 [<c04300e0>] ? aes_dec_blk+0x77c/0xb6c
 [<c06a2c20>] ? intel_idle+0xd0/0x130
 [<c07ffdd6>] ? cpuidle_idle_call+0xa6/0x1f0
 [<c04023cc>] ? cpu_idle+0x9c/0xe0
 [<c0908c85>] ? rest_init+0x5d/0x68
 [<c0bb2751>] ? start_kernel+0x357/0x35d
 [<c0bb217f>] ? loglevel+0x2b/0x2b
 [<c0bb2078>] ? i386_start_kernel+0x78/0x7d
---[ end trace 63a55f6565db3c43 ]---
tg3 0000:02:00.0: p2p1: transmit timed out, resetting
hrtimer: interrupt took 7973146 ns

After the warning, the following lines are printed:

tg3 0000:02:00.0: p2p1: 0x00000000: 0x171314e4, 0x00100406, 0x02000002, 0x00000010

I'll attach a full log later on.

Version-Release number of selected component (if applicable):

Fedora release 17 (Beefy Miracle)
Linux len.housecafe.de 3.3.4-5.fc17.i686 #1 SMP Mon May 7 17:45:26 UTC 2012 i686 i686 i386 GNU/Linux

$ ethtool -i p2p1
driver: tg3
version: 3.122
firmware-version: sb v3.04
bus-info: 0000:02:00.0
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes
supports-priv-flags: no

$ lspci -v
[...]
02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5906M Fast Ethernet PCI Express (rev 02)
	Subsystem: Lenovo IdeaPad S10e
	Flags: bus master, fast devsel, latency 0, IRQ 43
	Memory at f0200000 (64-bit, non-prefetchable) [size=64K]
	Expansion ROM at <ignored> [disabled]
	Capabilities: [48] Power Management version 3
	Capabilities: [50] Vital Product Data
	Capabilities: [58] Vendor Specific Information: Len=78 <?>
	Capabilities: [e8] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [d0] Express Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [13c] Virtual Channel
	Capabilities: [160] Device Serial Number 00-23-8b-ff-fe-35-65-95
	Kernel driver in use: tg3

How reproducible:


This happened two times so far (with a reboot inbetween), at both times the NIC was somewhat busy (constant ~200 KB/s TX & RX).


Steps to Reproduce:
1. Boot system
2. Generate some network load
3. Wait a few hours

Actual results:

WARNING is printed, tg3 stops working

Expected results:

NIC continues to work.

Additional info:

There are similar bugs filed with "WARNING: at net/sched/sch_generic.c:256" (e.g. #715137, #717211, #552288) but none for the tg3 driver, AFAICS.
Comment 1 Josh Boyer 2012-05-25 09:13:56 EDT

*** This bug has been marked as a duplicate of bug 825123 ***

Note You need to log in before you can comment on or make changes to this bug.