Bug 825153 - srpm rebuild fails
Summary: srpm rebuild fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: numad
Version: 6.3
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Jan Synacek
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 836160 830919
TreeView+ depends on / blocked
 
Reported: 2012-05-25 09:02 UTC by Ales Zelinka
Modified: 2013-02-21 08:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 08:57:28 UTC
Target Upstream Version:


Attachments (Terms of Use)
[Patch] Remove -lpthread from Makefile (209 bytes, patch)
2012-09-11 06:41 UTC, Jan Synacek
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0358 normal SHIPPED_LIVE numad bug fix and enhancement update 2013-02-20 20:53:13 UTC

Description Ales Zelinka 2012-05-25 09:02:10 UTC
Description of problem:
The -lpthread from Makefile's
numad: numad.o -lpthread

causes this error on some x64_64 machines:
+ export LANG
+ unset DISPLAY
+ make 'CFLAGS=-std=gnu99 -g' LDFLAGS=-lpthread
Makefile:61: .depend: No such file or directory
cc -MM -DDEPS_RUN -I. numad.c > .depend.X && mv .depend.X .depend
cc -std=gnu99 -g -I. -D__thread=""   -c -o numad.o numad.c
cc -lpthread  numad.o /usr/lib/libpthread.so   -o numad
/usr/bin/ld: skipping incompatible /lib/libpthread.so.0 when searching for /lib/libpthread.so.0
/usr/bin/ld: cannot find /lib/libpthread.so.0
collect2: ld returned 1 exit status
make: *** [numad] Error 1



Version-Release number of selected component (if applicable):
numad-0.5-4.20120522git.el6.x86_64.rpm

How reproducible:
on some machines, not sure what's the difference

Additional info:
-lpthread is also added via spec file, the makefile one isn't necessary

Comment 1 Petr Holasek 2012-09-05 13:12:45 UTC
I've got the same error with raw git repo 334278ff3d774 from fedorahosted.org on F17. Suprisingly, fedpkg scratch-build was completed successfully.

Comment 2 Jan Synacek 2012-09-11 06:41:38 UTC
Created attachment 611666 [details]
[Patch] Remove -lpthread from Makefile

Remove -lpthread from Makefile so the flag only gets added from the specfile.

Comment 12 errata-xmlrpc 2013-02-21 08:57:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0358.html


Note You need to log in before you can comment on or make changes to this bug.