Bug 825168 - 3.1 (cloned to 6.3.z) - KVM version is N/A in RHEVM
3.1 (cloned to 6.3.z) - KVM version is N/A in RHEVM
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Douglas Schilling Landgraf
Tomas Dosek
infra
: Regression, ZStream
Depends On:
Blocks: 830787 834105
  Show dependency treegraph
 
Reported: 2012-05-25 05:37 EDT by Guohua Ouyang
Modified: 2012-08-10 11:07 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Red Hat Enterprise Linux 6.3 included the new qemu-kvm-rhev package. Existing versions of VDSM were not able to correctly determine the version information for hosts with qemu-kvm-rhev installed. As a result the KVM version would be listed as 'N/A' for these hosts in the Red Hat Enterprise Virtualization Manager. VDSM has been updated and will now correctly report the KVM version for hosts, regardless of which qemu-kvm package is installed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-23 11:15:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guohua Ouyang 2012-05-25 05:37:34 EDT
Description of problem:
KVM version is N/A after rhevh show up in rhevm.
if upgrade from rhevh-6.2-20111117.0 build to rhevh-6.3-20120523.1 build,
the kvm version displayed wrong version 0.12.1.2 - 2.209.el6

# rpm -qa | grep kvm
qemu-kvm-rhev-0.12.1.2-2.295.el6.x86_64

# rpm -qa | grep vdsm
vdsm-4.9-113.1.el6.x86_64

with rhevh-6.2-20111117.0 build, the kvm version is 0.12.1.2 - 2.209.el6 , so it's a regression issue of vdsm.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120523.1.el6
vdsm-4.9-113.1.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. register rhevh to rhevm

Actual results:
KVM version is N/A in RHEVM 

Expected results:
KVM version is 0.12.1.2-2.295.el6
Comment 2 Mike Burns 2012-05-25 07:19:31 EDT
This is due to the move to qemu-kvm-rhev in 6.3.  

in vdsm/caps.py


    KEY_PACKAGES = ['qemu-kvm', 'qemu-img',
                    'vdsm', 'spice-server', 'libvirt']

    pkgs = {'kernel': kernelDict()}
    try:
        for pkg in KEY_PACKAGES:
            rc, out, err = utils.execCmd([constants.EXT_RPM, '-q', '--qf',
                  '%{NAME}\t%{VERSION}\t%{RELEASE}\t%{BUILDTIME}\n', pkg],
                  sudo=False)
            if rc: continue
            line = out[-1]
            n, v, r, t = line.split()
            pkgs[pkg] = dict(version=v, release=r, buildtime=t)
    except:
        logging.error('', exc_info=True)

    return pkgs


This could be solved using "--whatprovides" flag to rpm command

            rc, out, err = utils.execCmd([constants.EXT_RPM, '-q', '--qf',
                  '%{NAME}\t%{VERSION}\t%{RELEASE}\t%{BUILDTIME}\n',
                  '--whatprovides', pkg], sudo=False)
Comment 9 Dan Kenigsberg 2012-06-23 11:15:09 EDT
now that the patch has been pushed to the rhev-3.1 branch (v4.9.6-14-6-g3a0496e), this bug has exhausted its purpose.
Comment 10 Stephen Gordon 2012-08-10 11:07:31 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Red Hat Enterprise Linux 6.3 included the new qemu-kvm-rhev package. Existing versions of VDSM were not able to correctly determine the version information for hosts with qemu-kvm-rhev installed. As a result the KVM version would be listed as 'N/A' for these hosts in the Red Hat Enterprise Virtualization Manager. VDSM has been updated and will now correctly report the KVM version for hosts, regardless of which qemu-kvm package is installed.

Note You need to log in before you can comment on or make changes to this bug.