Bug 825188 - make scsi-testsuite pass
make scsi-testsuite pass
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Miroslav Rezanina
Virtualization Bugs
:
Depends On:
Blocks: 833566 1038945
  Show dependency treegraph
 
Reported: 2012-05-25 06:30 EDT by Paolo Bonzini
Modified: 2013-12-06 03:32 EST (History)
14 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.320.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1038945 (view as bug list)
Environment:
Last Closed: 2013-02-21 02:36:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paolo Bonzini 2012-05-25 06:30:14 EDT
The testsuite at git://github.com/bonzini/scsi-testsuite.git has four failing tests (1,2,5,6 - reported by mrezanin).  Backport enough fixes from upstream QEMU to make it succeed.
Comment 1 RHEL Product and Program Management 2012-07-10 04:14:04 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2012-07-10 22:08:43 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 5 Sibiao Luo 2012-09-06 06:36:59 EDT
hi Paolo Bonzini,

   I test it on qemu-kvm-0.12.1.2-2.311.el6.x86_64 with scsi-hd system and data disk, the result is that the 001,002,003,004,005,006 can pass, but the 007 fails.

host info:
# uname -r && rpm -q qemu-kvm
2.6.32-303.el6.x86_64
qemu-kvm-0.12.1.2-2.311.el6.x86_6
guest info:
# uname -r
2.6.32-303.el6.x86_64

in the guest:
# lsscsi 
[1:0:0:0]    cd/dvd  QEMU     QEMU DVD-ROM     0.12  /dev/sr0 
[2:0:0:0]    disk    QEMU     QEMU HARDDISK    0.12  /dev/sda 
[3:0:1:1]    disk    QEMU     QEMU HARDDISK    0.12  /dev/sdb 
[root@localhost scsi-testsuite]# ./check 
PLATFORM      -- Linux/x86_64 localhost 2.6.32-279.el6.x86_64

001 0s ...
002 0s ...
003 0s ...
004 0s ...
005 0s ...
006 0s ...
007	 - output mismatch (see 007.out.bad)
--- 007.out	2012-09-06 18:00:58.974196308 +0800
+++ 007.out.bad	2012-09-06 18:23:21.333197168 +0800
@@ -2,11 +2,15 @@
      0x0	Supported VPD pages
      0x83	Device identification
     cdb to send: 12 01 83 00 02 00
-SCSI Status: Good
+SCSI Status: Check Condition
 
 Sense Information:
-sense buffer empty
+ Fixed format, current;  Sense key: Illegal Request
+ Additional sense: Invalid field in cdb
+ Raw sense data (in hex):
+        70 00 05 00 00 00 00 0a  00 00 00 00 24 00 00 00
+        00 00
 
 Received 2 bytes of data:
- 00     00 83                                               ..
+ 00     00 00                                               ..
 *** done
Failures: 007
Failed 1 of 7 tests

above all, re-assigned this bug to fix this issue, pls let me know if any problem.

Best Regards & thx,
sluo
Comment 6 Miroslav Rezanina 2012-09-13 02:33:17 EDT
Due to shortening names of patch files when committing into dist-git, two of the required patches had same name so one of them is masked and not included in the build. Need to solve this with minovotn.
Comment 7 Eduardo Habkost 2012-09-20 11:57:46 EDT
Missing patch was added on qemu-kvm-0.12.1.2-2.316.el6.src.rpm.
Comment 11 Shaolong Hu 2012-12-21 00:05:59 EST
Verified on qemu-kvm-rhev-0.12.1.2-2.348.el6.x86_64:

all 7 tests pass.
Comment 12 errata-xmlrpc 2013-02-21 02:36:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0527.html

Note You need to log in before you can comment on or make changes to this bug.