Bug 825203 - Don't customize V4L/DVB tuners or frontends
Don't customize V4L/DVB tuners or frontends
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
All Linux
low Severity low
: ---
: ---
Assigned To: Mauro Carvalho Chehab
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 07:04 EDT by Mauro Carvalho Chehab
Modified: 2013-07-04 18:59 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 22:32:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mauro Carvalho Chehab 2012-05-25 07:04:57 EDT
Description of problem:

As complained upstream:
http://comments.gmane.org/gmane.linux.drivers.video-input-infrastructure/48798

On Thu, May 24, 2012 at 3:33 PM, Mauro Carvalho Chehab
<mchehab <at> redhat.com> wrote:
>
> The Kconfig default for DVB_FE_CUSTOMISE is 'n'. So, if no DVB bridge is selected,
> nothing will be compiled.

Sadly, it looks like the default for distro kernels is 'y'.

Basically, DVB_FE_CUSTOMISE and CONFIG_MEDIA_TUNER_CUSTOMISE are two options inside the media subsystem that allows embedded systems to unselect the not needed tuners and frontends. No distro should be using it, as the corresponding drivers are automatically selected by default, when a DVB or V4L driver is
selected.

Version-Release number of selected component (if applicable):

All Fedora versions.

Expected results:

unselect DVB_FE_CUSTOMISE and CONFIG_MEDIA_TUNER_CUSTOMISE Kconfig options and remove the manual entries for tuners and frontends.
Comment 1 Dave Jones 2012-05-25 11:33:11 EDT
we did have a reason for doing it, but it was so long ago I've long forgotten what it was.  Some ugly dependancy problem is all I can remember, the details are lost.
Comment 2 Mauro Carvalho Chehab 2012-05-25 12:20:06 EDT
(In reply to comment #1)
> we did have a reason for doing it, but it was so long ago I've long
> forgotten what it was.  Some ugly dependancy problem is all I can remember,
> the details are lost.

Maybe it were due to some legacy problems with the Kconfig autoselect logic. Those got fixed sometime ago. Anyway, if we get anything wrong, let's fix the
dependency issues at Kconfig.

Btw, I double-checked with F17: the only driver that got disabled by this change is the DVB_DUMMY_FE frontend. As this is just a dummy driver written to help DVB developers to write real frontends, I don't expect to have any issues with this change.

As a side note, I'm proposing to make those *CUSTOMISE options dependent on EXPERT for 3.5. So, those options will likely disappear anyway on 3.5 and upper, as EXPERT is not selected on Fedora.
Comment 3 Fedora Update System 2012-06-03 09:20:31 EDT
kernel-3.4.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.4.0-1.fc17
Comment 4 Fedora Update System 2012-06-03 19:26:59 EDT
Package kernel-3.4.0-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.4.0-1.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8824/kernel-3.4.0-1.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-06-05 07:18:36 EDT
kernel-3.3.8-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.3.8-1.fc16
Comment 6 Fedora Update System 2012-06-06 22:29:35 EDT
Package kernel-3.3.8-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.3.8-1.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8890/kernel-3.3.8-1.fc16
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-06-06 22:32:53 EDT
kernel-3.4.0-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2012-06-13 17:29:44 EDT
kernel-3.3.8-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 John Pilkington 2012-07-08 07:23:14 EDT
Under kernel 3.4.2-1.fc16.x86_64  all my dvb-t hardware reports FE_GET_INFO ioctl failed, in mythtvsetup, MythTV 0.24.3.  kde version 4.8.4

After reverting to 3.3.7-1 all works as expected.

http://www.gossamer-threads.com/lists/mythtv/users/522467#522467
Comment 10 Paul Wilson 2013-06-19 22:05:13 EDT
I'm getting this with  3.8.13-100.fc17.i686
so has this been regressed or is it not been pushed out to F17 yet?
Comment 11 Josh Boyer 2013-06-20 08:58:18 EDT
(In reply to Paul Wilson from comment #10)
> I'm getting this with  3.8.13-100.fc17.i686
> so has this been regressed or is it not been pushed out to F17 yet?

Getting what exactly?

The config change to not use DVB_FE_CUSTOMISE and MEDIA_TUNER_CUSTOMISE is still in F17.
Comment 12 John Pilkington 2013-06-20 10:35:52 EDT
The problem was as described in the link in Comment 9.  It still exists in f17.  The link to this bug was speculative, based on the changelog of the first kernel that exhibited the bug.  It's probably spurious.  Thought to be the result of a race condition in mythtvsetup and/or several video drivers.  

http://code.mythtv.org/trac/ticket/11539#comment:1

which includes a link to

https://patchwork.kernel.org/patch/1309251/
Comment 13 Paul Wilson 2013-06-20 18:30:58 EDT
I'm getting the following error:

FE_GET_INFO ioctl failed (/dev/dvb/adapter3/frontend0)
eno: No such device (19)

Note You need to log in before you can comment on or make changes to this bug.