Bug 825215 - Subscription-manager unregister error : SubscriptionManagerError: No such file or directory(on rhevh)
Subscription-manager unregister error : SubscriptionManagerError: No such fi...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-who (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Radek Novacek
Virtualization Bugs
:
Depends On:
Blocks: 771481
  Show dependency treegraph
 
Reported: 2012-05-25 07:26 EDT by yqiao
Modified: 2016-11-30 19:30 EST (History)
5 users (show)

See Also:
Fixed In Version: virt-who-0.8-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:50:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
lzhuang: needinfo+


Attachments (Terms of Use)

  None (edit)
Description yqiao 2012-05-25 07:26:04 EDT
Description of problem:
When virt-who is running, and unregister rhev-h host, it will report:
SubscriptionManagerError: No such file or directory
Error in communication with candlepin, trying to recover
Unable to read certificate, system is not registered or you are not root


Version-Release number of selected component (if applicable):

virt-who-0.6-6.el6.noarch
subscription-manager-0.99.14-1.el6.x86_64
subscription-manager-firstboot-0.99.14-1.el6.x86_64
subscription-manager-gnome-0.99.14-1.el6.x86_64
candlepin-tomcat6-0.6.3-1.el6_2.noarch
candlepin-0.6.3-1.el6_2.noarch
katello-headpin-all-0.2.9-1.el6_2.noarch
katello-headpin-0.2.9-1.el6_2.noarch
thumbslug-0.0.24-1.el6_2.noarch


How reproducible:
100%

Steps to Reproduce:

1.Register rhevh host to SAM, 
2.Start virt-who service
3.Unregister host from SAM server.
4.Check virt-who output info 
  
Actual results:

Sending list of uuids: ['23abb461-f4fe-444c-bb2e-f8209abe4662', '34711c30-8c13-4a31-bf92-5740e6a4e0a3', '98c8b255-99de-408c-88d9-3303bf57cf78', 'a7a614ab-affe-47aa-9527-05262e43f802']
No such file or directory
Traceback (most recent call last):
  File "/usr/share/virt-who/virt-who.py", line 147, in _send
  File "/usr/share/virt-who/subscriptionmanager.py", line 81, in sendVirtGuests
SubscriptionManagerError: No such file or directory
Error in communication with candlepin, trying to recover
Unable to read certificate, system is not registered or you are not root

Expected result:
no error info and only show the info as "Unable to read certificate, system is not registered or you are not root
"

Additional info:
Comment 3 Radek Novacek 2012-05-28 03:46:10 EDT
Yqiao, can you post here content of the file /etc/sysconfig/virt-who ?
Comment 4 yqiao 2012-05-30 06:19:25 EDT
(In reply to comment #3)
> Yqiao, can you post here content of the file /etc/sysconfig/virt-who ?

yeah, i config the virt-who as follow:
VIRTWHO_BACKGROUND=1
VIRTWHO_DEBUG=1
VIRTWHO_VDSM=1
VIRTWHO_INTERVAL=2
Comment 5 Radek Novacek 2012-05-30 07:30:16 EDT
Thank you.

Can you try to reproduce this bug with

VIRTWHO_DEBUG=0

If the error output won't appear, I would say that it isn't a bug. Having the backtrace in debug mode is extremely helpful for finding what is the problem. Of course, this error should be hidden in non-debug mode.
Comment 7 RHEL Product and Program Management 2012-07-10 04:07:09 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2012-07-10 22:02:40 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 9 Radek Novacek 2012-08-15 03:42:47 EDT
ping, can you reproduce this bug with VIRTWHO_DEBUG=0?
Comment 10 lzhuang 2012-09-17 04:07:56 EDT
1. # cat /etc/sysconfig/virt-who 
   VIRTWHO_BACKGROUND=1
   VIRTWHO_DEBUG=0
                ^^^
   VIRTWHO_INTERVAL=2
2. It still prints error log after rhevh is unregistered:
2012-09-17 08:02:10,541 [ERROR]  @virt-who.py:165 - No such file or directory
Traceback (most recent call last):
  File "/usr/share/virt-who/virt-who.py", line 147, in _send
  File "/usr/share/virt-who/subscriptionmanager.py", line 81, in sendVirtGuests
SubscriptionManagerError: No such file or directory
2012-09-17 08:02:10,541 [ERROR]  @virt-who.py:169 - Error in communication with candlepin, trying to recover
2012-09-17 08:02:10,542 [ERROR]  @subscriptionmanager.py:52 - Unable to read certificate, system is not registered or you are not root
3. version info:
virt-who-0.6-6.el6.noarch

(In reply to comment #9)
> ping, can you reproduce this bug with VIRTWHO_DEBUG=0?
Comment 11 Radek Novacek 2012-09-25 04:00:32 EDT
This bug will be fixed in next release of virt-who. Tracebacks will be only saved to the log file and not printed on the terminal.
Comment 12 Radek Novacek 2012-09-26 03:36:25 EDT
This bug has been fixed in virt-who-0.8-1.el6.
Comment 15 Hui Wang 2013-01-16 21:29:06 EST
Verified the issue, the result is PASS.
Version:
virt-who-0.8-5.el6.noarch
subscription-manager-1.1.21-1.el6.x86_64

1. # cat /etc/sysconfig/virt-who 
   VIRTWHO_BACKGROUND=1
   VIRTWHO_DEBUG=0
                ^^^
   VIRTWHO_VDSM=1
2. Start virt-who service
3. RHEVH registered to SAM
4. RHEVH Unregistered from SAM
5. Check the log: There are no the error:"SubscriptionManagerError: No such file or directory "

tail -f /var/log/rhsm/rhsm.log
2013-01-17 02:19:51,190 [ERROR]  @virt-who.py:186 - Error in communication with virt backend, trying to recover:
Traceback (most recent call last):
  File "/usr/share/virt-who/virt-who.py", line 178, in _send
  File "/usr/share/virt-who/vdsm.py", line 99, in listDomains
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1199, in __call__
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1489, in __request
  File "/usr/lib64/python2.6/site-packages/M2Crypto/m2xmlrpclib.py", line 49, in request
  File "/usr/lib64/python2.6/httplib.py", line 908, in endheaders
  File "/usr/lib64/python2.6/httplib.py", line 780, in _send_output
  File "/usr/lib64/python2.6/httplib.py", line 739, in send
  File "/usr/lib64/python2.6/site-packages/M2Crypto/httpslib.py", line 73, in connect
error: [Errno 111] Connection refused
2013-01-17 02:19:51,202 [ERROR]  @virt-who.py:189 - Unable to recover, retry in 60 seconds.
Comment 17 errata-xmlrpc 2013-02-21 04:50:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0374.html

Note You need to log in before you can comment on or make changes to this bug.