Bug 825245 - Gear DNS entry in haproxy config file is not changed after domain is altered
Gear DNS entry in haproxy config file is not changed after domain is altered
Status: CLOSED DUPLICATE of bug 822080
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
1.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Ram Ranganathan
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 08:45 EDT by Xiaoli Tian
Modified: 2013-03-03 18:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-25 14:29:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaoli Tian 2012-05-25 08:45:15 EDT
Description of problem:
Original domain is testmongo, new domain is testmongo2, 
The GearDNS has been changed to use testmongo2, but the entry in haproxy.cfg is still using testmongo like:

    server gear-678b5a7d81-testmongo 10.93.35.98:35536 check fall 2 rise 3 inter 2000 cookie 678b5a7d81-testmongo2 2
    server gear-c1639c1749-testmongo 10.93.35.98:35556 check fall 2 rise 3 inter 2000 cookie c1639c1749-testmongo2 2

Which will cause $appurl/haproxy-status/  still shows the old domain, not sure if anywhere else will use this entry.


Version-Release number of selected component (if applicable):
devenv_1802 and all the old env.

How reproducible:
Always

Steps to Reproduce:
1.Create an scaling app on domain1
2.Alter domain to domain2
3.Check $OPENSHIFT_APP_DIR/haproxy-1.4/conf/haproxy.cfg
  
Actual results:
The entry is not updated

Expected results:
The entry should be updated as well

Additional info:
Comment 1 Ram Ranganathan 2012-05-25 14:29:54 EDT
This shouldn't really affect haproxy functioning. Its just a server tag that is used.
Would be more of a nice to have.

Also would be good to have the mcollective logs attached because I suspect the connectors are not being called.  Verified with rchopra that's the case -- we don't call connectors on update namespace. That explains why this was not updated.  

Marking this a duplicate of  bugz 822080

*** This bug has been marked as a duplicate of bug 822080 ***

Note You need to log in before you can comment on or make changes to this bug.