Bug 825260 - Plugin [JMX] is required by plugins [[DroolsRHQPlugin]] but it does not exist in the dependency graph yet error after upgrade from jon3.0.1.GA to jon3.1.0.ER4
Plugin [JMX] is required by plugins [[DroolsRHQPlugin]] but it does not exist...
Status: CLOSED WORKSFORME
Product: RHQ Project
Classification: Other
Component: Core Server, Installer, Plugins (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: JON 3.1.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 09:38 EDT by Filip Brychta
Modified: 2012-05-29 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-29 12:22:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhq server log (26.75 KB, application/x-gzip)
2012-05-25 09:38 EDT, Filip Brychta
no flags Details

  None (edit)
Description Filip Brychta 2012-05-25 09:38:03 EDT
Created attachment 586871 [details]
rhq server log

Description of problem:
$subject. Same error for several other plugins (see attached log) 

Version-Release number of selected component (if applicable):
jon3.1.0.ER4

Steps to Reproduce:
1.jon3.0.1.GA + eap plugin installed and running using oracle database
2.follow upgrade manual
3.check rhq-server-log4j.log
  
Actual results:
2012-05-23 16:48:22,328 ERROR [org.rhq.enterprise.server.core.plugin.ProductPluginDeployer] Plugin [JMX] is required by plugins [[DroolsRHQPlugin]] but it does not exist in the dependency graph yet
Comment 1 Mike Foley 2012-05-29 10:11:13 EDT
filip ... any other functional regressions beyond the error in the log?  can you attach the whole log?  retest in ER6?
Comment 2 Mike Foley 2012-05-29 10:41:32 EDT
per BZ Triage 5/29/2012 (ccrouch, loleary, asantos, mfoley, myarborough) moving these to JON 3.1.1 or later
Comment 3 Filip Brychta 2012-05-29 11:40:50 EDT
I'm sorry, but i'm not able to reproduce this bug. Complete server log is all i can provide
Comment 4 Charles Crouch 2012-05-29 12:22:07 EDT
(11:02:14 AM) ips: ccrouch: i was unable to reproduce by deploying the brms plugin pack on top of master
(11:02:39 AM) ips: i also tried deploying some other new plugins on top of my install and no errors
(11:03:47 AM) ips: i suspect filip had something funky in his environment
(11:04:15 AM) ips: because i also saw this in his log: 2012-05-23 16:37:35,800 ERROR [org.rhq.enterprise.server.core.plugin.PluginDeploymentScanner] Scan failed. Cause: java.lang.Exception:File [/home/jon/jon-server-3.1.0.ER4/jbossas/server/default/deploy/rhq.ear/rhq-downloads/rhq-plugins/hornetq-jopr-plugin-2.0.0.Final.jar] is not a valid jarfile -  it is either corrupted or file has not been fully written yet.


Closing as can't reproduced based on Ian's comments

Note You need to log in before you can comment on or make changes to this bug.