Bug 825286 - subscription-manager service-level --show
subscription-manager service-level --show
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Alex Wood
Entitlement Bugs
: QA-Closed
Depends On:
Blocks: 771748 827225
  Show dependency treegraph
 
Reported: 2012-05-25 11:00 EDT by Matt Reid
Modified: 2013-01-07 22:52 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:52:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2012-05-25 11:00:34 EDT
Description of problem:
We handle unset service levels a little differently than unset release versions. service-level --show returns "Current service level:", whereas release --show returns "Release not set". I think saying it isn't set is clearer than showing an empty string.

Could we update service-level to show "Service level preference not set" for cases where it isn't set?

Version-Release number of selected component (if applicable):
subscription-manager-1.0.2-1.git.2.2b23e6e
Comment 1 Alex Wood 2012-06-04 11:43:25 EDT
commit 614fbddbd53c74ea580ad0c980b2a98bda587988
Author: Alex Wood <awood@redhat.com>
Date:   Mon Jun 4 11:21:10 2012 -0400

    825286: Handle unset service levels in a manner similar to unset release versions.
Comment 2 spandey 2012-06-15 06:15:13 EDT
Verified using following rpm 

subscription-manager-1.0.3-1.git.69.b87abd7.el5
subscription-manager-firstboot-1.0.3-1.git.69.b87abd7.el5
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
subscription-manager-migration-1.0.3-1.git.69.b87abd7.el5
subscription-manager-gui-1.0.3-1.git.69.b87abd7.el5


[root@dhcp193-122 ~]# subscription-manager service-level --show
Service level preference not set

tested with unset 

[root@dhcp193-122 ~]# subscription-manager service-level --unset
Service level preference has been unset
[root@dhcp193-122 ~]# subscription-manager service-level --show
Service level preference not set

Working fine resolving defect as verified
Comment 4 errata-xmlrpc 2013-01-07 22:52:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.