Bug 825293 - Validating WSDL imported from Amazon.com fails with NPE
Validating WSDL imported from Amazon.com fails with NPE
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Tooling (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: ER2
: 6.0
Assigned To: Van Halbert
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 11:09 EDT by Len DiMaggio
Modified: 2014-07-09 01:00 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
If a user tried to import a WSDL from Amazon.com into a web service model in Teiid Designer, they encountered a null-pointer error as the WSDLAnalyzer was unable to process the file. Since the null pointer error in the WSDLValidator is presented as a warning, the code has been changed to allow the import wizard to proceed when only warnings are present. Note that, proceeding with this import may cause issues with model generation.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-06 10:37:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 323157 None None None Never
JBoss Issue Tracker TEIIDDES-1364 Major Closed Validating WSDL imported from Amazon.com fails with NPE 2014-02-04 09:05:13 EST

  None (edit)
Description Len DiMaggio 2012-05-25 11:09:57 EDT
Description of problem:

Link to: JBDS-2130

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 3 JBoss JIRA Server 2012-06-12 15:38:42 EDT
Len DiMaggio <ldimaggi@redhat.com> made a comment on jira JBDS-2130

Van Halbert 2012-05-25 11:22:16 EDT

Because this is a WTP issue, Designer is hoping it will be fixed by its 8.0 release (SOA 6).
Comment 4 JBoss JIRA Server 2012-06-12 18:25:39 EDT
Brian Fitzpatrick <bfitzpat@redhat.com> made a comment on jira JBDS-2130

Considering that nobody has looked at https://bugs.eclipse.org/bugs/show_bug.cgi?id=323157 since Ted added his comment, we may need to urge the WTP folks to work on this through Max or perhaps Rob Stryker. But with a release just about out the door and the summer slow season coming I can't imagine this will be fixed soon. Perhaps for the first maintenance release of the year in September?
Comment 5 JBoss JIRA Server 2012-06-12 20:30:59 EDT
Nick Boldt <nboldt@redhat.com> made a comment on jira JBDS-2130

0. SOA Tooling 5.0.0.CR1-SOA depends on Eclipse 3.7.2 & Web Tools 3.3.2 (Indigo SR2).

1. Eclipse 3.7.2 / Web Tools 3.3.2 (Indigo SR2) is at end of development. It is HIGHLY unlikely https://bugs.eclipse.org/bugs/show_bug.cgi?id=323157 will be fixed in that stream.

2. Even if this DOES get fixed for the late September Juno SR1 release (Eclipse 4.2.1/3.8.1, WTP 3.4.1), that won't help it get fixed for 5.0.0.CR1-SOA, since that builds on Eclipse 3.7.2/WTP3.3.2.

3. Therefore you need to either set a more reasonable target for this to be fixed (6.0.0.M1-SOA), or reject this issue as WONTFIX (rejected by upstream).
Comment 6 David Le Sage 2012-06-12 23:16:13 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
If a user tries to import a WSDL from Amazon.com into a web service model in Teiid Designer, they will encounter a null-pointer error as the WSDLAnalyzer is unable to process the file.
Comment 7 JBoss JIRA Server 2012-07-17 16:24:35 EDT
Ted Jones <tejones@redhat.com> made a comment on jira TEIIDDES-1364

Since other valid WSDLs may be hit the same issue, we will remove the restriction in the wizard and allow the user to continue with errors with a warning that results may be unpredictable. The warning should read like: "The WS-I Basic Profile 1.1 validation process encountered 1 or more warnings or errors. Continuing with the import may result in unexpected behavior and errors.".
Comment 8 JBoss JIRA Server 2012-07-17 16:30:52 EDT
Ted Jones <tejones@redhat.com> made a comment on jira TEIIDDES-1364

Since other valid WSDLs may hit the same issue, we will remove the restriction in the wizard and allow the user to continue with errors with a warning that results may be unpredictable. The warning should read like: "The WS-I Basic Profile 1.1 validation process encountered 1 or more warnings or errors. Continuing with the import may result in unexpected behavior and errors.".
Comment 9 JBoss JIRA Server 2013-02-07 08:26:10 EST
Van Halbert <vhalbert@jboss.org> made a comment on jira TEIIDDES-1364

Ted, 

Is there any followup changes that will be required if JBDS-2130 is fixed?  If not, it sounds like the solution was to remove the restriction.
Comment 10 JBoss JIRA Server 2013-02-07 08:45:30 EST
Ted Jones <tejones@redhat.com> made a comment on jira TEIIDDES-1364

I am adding the warning for 8.1, but will not resolve this Jira (I will mark it partially fixed). Once the NPE is fixed in the WSDL validator, I will remove the warning and resolve this Jira. It looks like https://bugs.eclipse.org/bugs/show_bug.cgi?id=323157 is getting some attention.
Comment 12 JBoss JIRA Server 2013-02-08 13:36:35 EST
Ted Jones <tejones@redhat.com> made a comment on jira TEIIDDES-1364

The NPE in the WTP WSDLValidator is presented as a general warning by the validator. Changed to allow proceeding in the wizard when only warnings are present. Also added a warning stating that proceeding may cause issues with model generation.
Comment 13 JBoss JIRA Server 2013-02-08 13:40:51 EST
Ted Jones <tejones@redhat.com> updated the status of jira TEIIDDES-1364 to Resolved
Comment 14 JBoss JIRA Server 2013-04-29 12:05:50 EDT
Barry LaFond <blafond@jboss.org> updated the status of jira TEIIDDES-1364 to Closed
Comment 19 belong 2013-11-19 18:22:08 EST
Fixed before GA - setting to requires_doc_text- accordingly
Comment 20 Lucie Fabrikova 2014-02-04 08:00:34 EST
Verified in JBDSIS-7.0.0.GA-GA + DV 6.0.0.GA.

Note You need to log in before you can comment on or make changes to this bug.