Bug 825294 - Gnome Shell crash when editing wsdl file
Gnome Shell crash when editing wsdl file
Status: CLOSED WORKSFORME
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: Tooling (Show other bugs)
5.3.0 GA
Unspecified Unspecified
unspecified Severity medium
: ---
: FUTURE
Assigned To: Default User
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 11:14 EDT by Len DiMaggio
Modified: 2016-02-17 04:19 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
An error arises when using the Gnome interface while editing a WDSL file. It triggers the Gnome shell to crash. As a result, edits to the WSDL will not be saved and the user may have to restart their computer to restore Gnome.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-17 04:16:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBIDE-10780 Blocker Closed Gnome Shell crash when editing wsdl file 2016-03-04 10:36 EST

  None (edit)
Description Len DiMaggio 2012-05-25 11:14:32 EDT
Description of problem:

Link to: JBIDE-10780

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 JBoss JIRA Server 2012-05-29 07:42:48 EDT
Max Rydahl Andersen <max.andersen@redhat.com> made a comment on jira JBIDE-10780

Okey - that bug I've not heard/seen about before. Most likely some inner Eclipse SWT bug not specific to WSDL but somehow WSDL triggers it.
Comment 2 JBoss JIRA Server 2012-05-30 04:13:04 EDT
Max Rydahl Andersen <max.andersen@redhat.com> made a comment on jira JBIDE-10780

Googling for gnome-shell.desktop killed shows that gnome shell isn't exactly the most stable piece of software out there.

I haven't been able to locate an eclipse specific bug at bugs.eclipse.org but I have found plenty of evidence that crashes to gnome shell occurs very easily and are dependent on users machine, driver and general setup.

Don't see how we can fix this unfortunately.
Comment 3 JBoss JIRA Server 2012-05-31 08:45:46 EDT
Len DiMaggio <ldimaggi@redhat.com> made a comment on jira JBIDE-10780

Pavol and Robert - on which OS are you seeing this?
Comment 4 JBoss JIRA Server 2012-05-31 08:48:32 EDT
Max Rydahl Andersen <max.andersen@redhat.com> made a comment on jira JBIDE-10780

Need to isolate which OS this is failing on.
Comment 5 JBoss JIRA Server 2012-05-31 08:59:01 EDT
Pavol Srna <psrna@redhat.com> made a comment on jira JBIDE-10780

In my case it was on Fedora 16.
Comment 6 JBoss JIRA Server 2012-05-31 08:59:22 EDT
Pavol Srna <psrna@redhat.com> made a comment on jira JBIDE-10780

In my case it was on Fedora 16 x86_64.
Comment 7 JBoss JIRA Server 2012-05-31 11:08:33 EDT
Robert Balent <rbalent@redhat.com> made a comment on jira JBIDE-10780

I've just reproduced it on clean install of Fedora 17 32 bit with OpenJDK Java 7 version "1.7.0_b147-icedtea" in VirtualBox.

/var/log/messages:
May 31 14:48:14 robotest kernel: [ 1268.909512] gnome-shell[1052]: segfault at c ip 00214788 sp bfbc2950 error 4 in libmutter.so.0.0.0[1a5000+be000]
May 31 14:48:24 robotest abrtd: Directory 'ccpp-2012-05-31-14:48:14-1052' creation detected
May 31 14:48:24 robotest abrt[1860]: Saved core dump of pid 1052 (/usr/bin/gnome-shell) to /var/spool/abrt/ccpp-2012-05-31-14:48:14-1052 (185696256 bytes)
May 31 14:48:26 robotest gnome-session[839]: WARNING: Application 'gnome-shell.desktop' killed by signal 11
May 31 14:48:49 robotest abrtd: New problem directory /var/spool/abrt/ccpp-2012-05-31-14:48:14-1052, processing


If it could be useful, I can upload kernel dump which was created by ABRT.


And my system is:
Archlinux x86_64
OpenJDK 1.6.0_24
gnome-shell 3.4.1-3 

I've already posted the error log in previous comment.
Comment 8 JBoss JIRA Server 2012-06-01 01:39:10 EDT
Max Rydahl Andersen <max.andersen@redhat.com> made a comment on jira JBIDE-10780

Its a long shot but could you use something that is not OpenJDK ? 

i.e. oracle/sun Java ? possibly Java6 ?
Comment 9 JBoss JIRA Server 2012-06-04 07:07:06 EDT
Robert Balent <rbalent@redhat.com> made a comment on jira JBIDE-10780

Same problem with Sun Java6 "1.6.0_32" on Fedora 17.
Comment 10 Len DiMaggio 2012-06-04 15:50:33 EDT
Is this reproducible 100% of the time?
Comment 11 JBoss JIRA Server 2012-06-05 10:53:26 EDT
Robert Balent <rbalent@redhat.com> made a comment on jira JBIDE-10780

Yes, 100% of the time when I was reproducing it.
Comment 12 Suz 2012-07-01 23:27:00 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
An error arises when using the Gnome interface while editing a WDSL file. It triggers the Gnome shell to crash. As a result, edits to the WSDL will not be saved and the user may have to restart their computer to restore Gnome.
Comment 13 JBoss JIRA Server 2012-11-07 14:10:10 EST
Robert (Bob) Brodt <bbrodt@redhat.com> made a comment on jira JBIDE-10780

Robert, can you describe the exact steps to reproduce this? What were you doing in the editor when the crash happened?

Again, this should probably be reported to the eclipse WTP group - have you entered a bug at https://bugs.eclipse.org/bugs/enter_bug.cgi?product=WTP%20Webservices ? If so, please post a link here.
Comment 14 JBoss JIRA Server 2012-11-13 05:39:14 EST
Andrej Podhradsky <apodhrad@redhat.com> made a comment on jira JBIDE-10780

Bug reported at https://bugs.eclipse.org/bugs/show_bug.cgi?id=394167
Comment 15 JBoss JIRA Server 2012-11-22 13:08:06 EST
Max Rydahl Andersen <max.andersen@redhat.com> made a comment on jira JBIDE-10780

Does this fail under Juno too ?
Comment 16 JBoss JIRA Server 2012-11-23 02:02:37 EST
Andrej Podhradsky <apodhrad@redhat.com> made a comment on jira JBIDE-10780

yes, this fails under juno too
Comment 17 JBoss JIRA Server 2013-02-01 03:09:40 EST
Andrej Podhradsky <apodhrad@redhat.com> made a comment on jira JBIDE-10780

the problem is still present
Comment 18 JBoss JIRA Server 2013-11-26 03:07:52 EST
Andrej Podhradsky <apodhrad@redhat.com> made a comment on jira JBIDE-10780

I was told that it isn't an eclipse bug but it is in the kernel (libmutter).
Comment 19 Andrej Podhradsky 2016-02-17 04:16:53 EST
The problem doesn't occur with GNOME Shell 3.16.4 (verified with Eclipse Mars / JBDS 9.1.0.Beta2 on Fedora 22 x86_64).
Comment 20 JBoss JIRA Server 2016-02-17 04:19:17 EST
Andrej Podhradsky <apodhrad@redhat.com> updated the status of jira JBIDE-10780 to Closed

Note You need to log in before you can comment on or make changes to this bug.