Bug 825296 - Regression - cannot create a new email notifier attachment in ESB editor
Regression - cannot create a new email notifier attachment in ESB editor
Status: CLOSED NOTABUG
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: Tooling (Show other bugs)
5.3.0 GA
Unspecified Unspecified
unspecified Severity urgent
: CR1
: 5.3.0 GA
Assigned To: Douglas Palmer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 11:18 EDT by Len DiMaggio
Modified: 2012-06-19 10:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-31 04:49:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBDS-2167 None Closed Regression - cannot create a new email notifier attachment in ESB editor 2012-05-31 04:55:05 EDT

  None (edit)
Description Len DiMaggio 2012-05-25 11:18:29 EDT
Description of problem:

Link to: JBDS-2167

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 JBoss JIRA Server 2012-05-29 13:16:43 EDT
Viacheslav Kabanovich <scabanovich@exadel.com> made a comment on jira JBDS-2167

This wizard was implemented as the file selector that required to select an existing resource in the project. So, what is exactly the problem, does the selector hides some resources? Could you please describe your usecase to be supported?
Comment 2 JBoss JIRA Server 2012-05-30 14:47:45 EDT
Viacheslav Kabanovich <scabanovich@exadel.com> made a comment on jira JBDS-2167

Len, I cannot reproduce the situation when the dialog fails to show an existing file inside Java source folders. Project, created by 'New ESB Project Wizard' has empty Java source folder, which may explain your screenshot. Do you mean that you would like to have an opportunity to type in any file name before it is added to the project?
Anyway, steps to reproduce, and an example of file location that failed to appear in the dialog would be of much help.
Comment 3 JBoss JIRA Server 2012-05-30 20:59:00 EDT
Len DiMaggio <ldimaggi@redhat.com> made a comment on jira JBDS-2167

Problem is not reproducible in CR1 build.
Comment 4 JBoss JIRA Server 2012-05-30 21:00:14 EDT
Len DiMaggio <ldimaggi@redhat.com> updated the status of jira JBDS-2167 to Closed
Comment 5 JBoss JIRA Server 2012-05-31 15:26:39 EDT
Viacheslav Kabanovich <scabanovich@exadel.com> made a comment on jira JBDS-2167

If it is not reproduced in CR1, then maybe it was a build problem. 

Meanwhile, I have looked into the source of org.jboss.soa.esb.helpers.Email, and it seems that maybe the dialog still should be improved. Now, the dialog shows jar files and allows to choose jar entries; but code in Email supposes that the attachment path targets a physical file rather than a resource accessible by the class loader. Will it make sense to remove jar files from the dialog? On the other hand, the dialog does not include esbcontent folder, which may contain files, will it make sense to add it to the dialog?

Note You need to log in before you can comment on or make changes to this bug.