Bug 825300 - embedded JVM discovery code tries to discover JVM process and connect to it via JMX remoting, rather than just using its parent Tomcat or JBoss AS Resource's EMSConnection, which is what it's supposed to do
embedded JVM discovery code tries to discover JVM process and connect to it v...
Status: CLOSED DUPLICATE of bug 823704
Product: RHQ Project
Classification: Other
Component: Plugin Container (Show other bugs)
4.3,4.4
Unspecified Unspecified
unspecified Severity high (vote)
: ---
: JON 3.1.1
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On: 802003
Blocks: 823704
  Show dependency treegraph
 
Reported: 2012-05-25 11:27 EDT by Charles Crouch
Modified: 2015-02-01 18:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 802003
Environment:
Last Closed: 2012-08-02 19:17:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2012-05-25 11:27:18 EDT
+++ This bug was initially created as a clone of Bug #802003 +++

Description of problem:

This message is output repeatedly in the logfile:

2012-03-10 06:42:41,984 ERROR [ResourceDiscoveryComponent.invoker.daemon-308] (rhq.core.pc.util.DiscoveryComponentProxyFactory)- Thread [ResourceDiscoveryComponent.invoker.daemon-308] was interrupted.
2012-03-10 06:42:41,984 WARN  [ResourceDiscoveryComponent.invoker.daemon-308] (rhq.core.pluginapi.inventory.ResourceContext)- Cannot get native process for resource [JVM] - discovery failed
java.lang.RuntimeException: Call to [org.rhq.plugins.jmx.EmbeddedJMXServerDiscoveryComponent.discoverResources()] with args [[org.rhq.core.pluginapi.inventory.ResourceDiscoveryContext@797d8adf]] was interrupted.
        at org.rhq.core.pc.util.DiscoveryComponentProxyFactory$ResourceDiscoveryComponentInvocationHandler.invokeInNewThread(DiscoveryComponentProxyFactory.java:224)
        at org.rhq.core.pc.util.DiscoveryComponentProxyFactory$ResourceDiscoveryComponentInvocationHandler.invoke(DiscoveryComponentProxyFactory.java:207)
        at $Proxy43.discoverResources(Unknown Source)
        at org.rhq.core.pluginapi.inventory.ResourceContext.getNativeProcess(ResourceContext.java:230)
        at org.rhq.plugins.jmx.EmbeddedJMXServerDiscoveryComponent.discoverResources(EmbeddedJMXServerDiscoveryComponent.java:70)
        at sun.reflect.GeneratedMethodAccessor36.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.rhq.core.pc.util.DiscoveryComponentProxyFactory$ComponentInvocationThread.call(DiscoveryComponentProxyFactory.java:292)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
        at java.util.concurrent.FutureTask.run(FutureTask.java:138)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:619)
Caused by: java.lang.InterruptedException
        at java.util.concurrent.locks.AbstractQueuedSynchronizer.tryAcquireSharedNanos(AbstractQueuedSynchronizer.java:1238)
        at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:227)
        at java.util.concurrent.FutureTask.get(FutureTask.java:91)
        at org.rhq.core.pc.util.DiscoveryComponentProxyFactory$ResourceDiscoveryComponentInvocationHandler.invokeInNewThread(DiscoveryComponentProxyFactory.java:220)
        ... 13 more

And 'Tomcat Server JVM' appears unavailable.

Version-Release number of selected component (if applicable):

rhq-jmx-plugin-4.3.0-SNAPSHOT.jar


How reproducible:

Seems to happen with Tomcat discovery.
Comment 1 Charles Crouch 2012-05-25 11:29:24 EDT
Cloned 802003 and targeting for JON3.1.1
Comment 2 Mike Foley 2012-05-29 10:41:14 EDT
per BZ Triage 5/29/2012 (ccrouch, loleary, asantos, mfoley, myarborough) moving these to JON 3.1.1 or later
Comment 3 Charles Crouch 2012-08-02 19:17:09 EDT

*** This bug has been marked as a duplicate of bug 823704 ***

Note You need to log in before you can comment on or make changes to this bug.