Bug 825321 - SSH Tech Preview feature enabled by default in ipa-client
SSH Tech Preview feature enabled by default in ipa-client
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
:
Depends On:
Blocks: 826592
  Show dependency treegraph
 
Reported: 2012-05-25 12:40 EDT by Martin Kosek
Modified: 2012-06-20 09:32 EDT (History)
5 users (show)

See Also:
Fixed In Version: ipa-2.2.0-16.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:32:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to configure ssh/sshd config files only when requested (6.52 KB, patch)
2012-05-25 13:06 EDT, Martin Kosek
no flags Details | Diff
Patch to configure ssh/sshd config files only when requested (9.45 KB, patch)
2012-05-25 13:45 EDT, Rob Crittenden
mkosek: review+
Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0819 normal SHIPPED_LIVE ipa bug fix and enhancement update 2012-06-19 16:34:17 EDT

  None (edit)
Description Martin Kosek 2012-05-25 12:40:51 EDT
Description of problem:

We configure SSSD Technical preview feature (SSH support) in ipa-client-install by default. This should only be enabled when user request it. Otherwise all users may get to serious issues with ssh command like the one I found today (Bug 825316)


Version-Release number of selected component (if applicable):
ipa-server-2.2.0-15.el6.x86_64

How reproducible:


Steps to Reproduce:
1. Install IPA server on a machine with default options
2. On that machine, check /etc/ssh/ssh_config
3.
  
Actual results:
SSSD SSH feature is enabled by default, bug 825316 can be reproduced

Expected results:
SSSD SSH feature is not enabled unless it is requested with a special flag, bug 825316 cannot be reproduced

Additional info:
Comment 2 Martin Kosek 2012-05-25 13:06:55 EDT
Created attachment 586903 [details]
Patch to configure ssh/sshd config files only when requested
Comment 3 Martin Kosek 2012-05-25 13:11:10 EDT
(In reply to comment #2)
> Created attachment 586903 [details]
> Patch to configure ssh/sshd config files only when requested

This patch only creates the options and adds the functionality, we also need to update the man pages.
Comment 4 Rob Crittenden 2012-05-25 13:45:27 EDT
Created attachment 586912 [details]
Patch to configure ssh/sshd config files only when requested

Updated man pages
Comment 6 Martin Kosek 2012-05-25 14:51:09 EDT
Comment on attachment 586912 [details]
Patch to configure ssh/sshd config files only when requested

Patch with the updated man pages looks ok.
Comment 9 errata-xmlrpc 2012-06-20 09:32:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0819.html

Note You need to log in before you can comment on or make changes to this bug.