Bug 825326 - [Fedora-17] ALPS touchpad recognized incorrectly as PS/2 generic mouse
[Fedora-17] ALPS touchpad recognized incorrectly as PS/2 generic mouse
Status: CLOSED DUPLICATE of bug 812111
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 13:05 EDT by Ye Myat Kaung
Modified: 2012-07-06 12:07 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-06 12:07:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ye Myat Kaung 2012-05-25 13:05:12 EDT
Description of problem:
Currently I'm using a DELL Inspiron 15R N5110 with Alps GlidePoint Touchpad. The touch pad only does clicking (left & right) and move around. No multi-touch/scrolling.

Version-Release number of selected component (if applicable):
3.3.7-1.fc17.x86_64 (updates-testing repo)

How reproducible:
Try scrolling vertically/horizontally without making use of the scrollbars.

Actual results:
clicking (left & right) and move around only

Expected results:
multi-touch/scrolling vertically/horizontally

Additional info:
should have scrolling vertically/horizontally

Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PS/2 Generic Mouse                        id=13   [slave  pointer  (2)]
⎜   ↳  USB OPTICAL MOUSE                        id=15   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ Laptop_Integrated_Webcam_HD               id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=14   [slave  keyboard (3)]

I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 Generic Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input5
U: Uniq=
H: Handlers=mouse0 event5
B: PROP=0
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=3

Do let me know if you need further information.
Comment 1 Josh Boyer 2012-07-05 14:47:49 EDT
Is this still happening in the 3.4.x kernel updates?
Comment 2 Ye Myat Kaung 2012-07-06 00:00:27 EDT
I've updates-testing repo enabled and currently, my F17 is at kernel version: 3.4.4-3.fc17.x86_64 but in the "Mouse and Touchpad" settings, I still don't have the options to configure multitouch stuff. So, yes, it's still happening in the 3.4.x kernel updates.
Comment 3 Josh Boyer 2012-07-06 09:19:38 EDT
Is only the multitouch functionality missing?  So normal "mouse" operation works, including side and horizontal scrolling?
Comment 4 Josh Boyer 2012-07-06 12:07:44 EDT

*** This bug has been marked as a duplicate of bug 812111 ***

Note You need to log in before you can comment on or make changes to this bug.