Bug 825329 - Application created from app template has no cartridges assigned to gears
Application created from app template has no cartridges assigned to gears
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
high Severity urgent
: ---
: ---
Assigned To: Fotios Lindiakos
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 13:25 EDT by Clayton Coleman
Modified: 2015-05-14 21:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 13:58:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Cartridge gears (44.71 KB, image/png)
2012-06-01 04:44 EDT, Xiaoli Tian
no flags Details

  None (edit)
Description Clayton Coleman 2012-05-25 13:25:50 EDT
Scenario:
1) Created an application template via application_templates/templates/rails/create.sh
2) Deployed it to my domain via rake descriptors:deploy as railstest
3) Went into the UI, got the following error

NoMethodError (undefined method `git_url=' for nil:NilClass):
  app/models/gear_group.rb:82:in `simplify'
  app/models/application.rb:38:in `gear_groups'
  app/controllers/applications_controller.rb:147:in `show'
  app/models/rest_api/railties/controller_runtime.rb:12:in `process_action'
  lib/streamline/railties/controller_runtime.rb:12:in `process_action'

This is because no cartridges were returned by gear groups

data": [
    {
      "cartridges": [],
      "name": "@@app",
      "gears": [
        {
          "id": "aa99188d57f64b699b88ad7d9d998c95",
          "state": "new"
        }
      ]
    }
  ],

This is either because the descriptor .yaml for the rails example is wrong (and needs to be updated) or because the REST API has bug that needs to be fixed.
Comment 1 Fotios Lindiakos 2012-05-30 14:42:40 EDT
This was fixed with a recent regeneration of template descriptors and the page now correctly shows gears
Comment 2 Xiaoli Tian 2012-06-01 04:44:02 EDT
Created attachment 588359 [details]
Cartridge gears

Verified it on integration env. cartrdge gears have been added to the page

Note You need to log in before you can comment on or make changes to this bug.