Bug 8254 - Dialin server wont work with Win98 clients
Dialin server wont work with Win98 clients
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks: 8350
  Show dependency treegraph
 
Reported: 2000-01-06 22:07 EST by rbiern01
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-21 14:21:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rbiern01 2000-01-06 22:07:33 EST
I have recently moved my existing RH 5.1 PPP server to a new RH 6.0 machine
and am now having problems getting it to work. I use mgetty and its AutoPPP
fucntion to start pppd using CHAP where there are options defined in two
files options.ttyS0 and ttyS1. The old RH 5.1 box worked fine with NT and
Win98 dialup clients but since moving over to RH 6.0 I initially couldnt
get NT clients to work, I had to add the -detach option to each of the
tty's option files. The main problem is that now the Win98 client appears
to be connected from there end, however they cannot do anything and their
modem lights are constantly on. Examining the /var/log/messages with kdebug
8 shows some weird error messages

Jan  6 17:03:26 celcius kernel:  6C Protocol
Jan  6 17:03:26 celcius pppd[1080]: Protocol-Reject for unsupported
protocol 0x7263
Jan  6 17:03:26 celcius pppd[1080]: Protocol-Reject for unsupported
protocol 0x7263

These messages get repeated forever until the client disconects

Here are my options

-detach
ttyS1 57600 crtscts
auth
debug
bsdcomp 12
deflate 12
vj-max-slots 12
require-chap
nodefaultroute
lock
:172.22.250.40
proxyarp
idle 900
ms-dns 172.22.250.10
ms-dns 172.22.250.11

My Windows NT clients do not have any problem connecting. This setup is
identical to the RH 5.1 setup apart from the -detach option as it would
work without it and would reset as soon as someone connected.
Comment 1 Nalin Dahyabhai 2000-01-21 14:21:59 EST
Were Windows 98 clients able to connect to your previous setup?  This protocol
rejection error is eerily similar to bug 8350 (both of you are seeing the same
protocol rejected).  Do the clients have any additional client-side components
(VPN, PPTP, etc.) installed?
Comment 2 Brent Fox 2002-06-05 11:51:44 EDT
Closing due to old age.

Note You need to log in before you can comment on or make changes to this bug.