Bug 825406 - RFE: Encryption passphrase prompt should probably tell the user if CAPSLOCK is on
Summary: RFE: Encryption passphrase prompt should probably tell the user if CAPSLOCK i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plymouth
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1655221 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-25 23:57 UTC by Luke Macken
Modified: 2019-11-18 01:17 UTC (History)
11 users (show)

Fixed In Version: plymouth-0.9.4-10.20191001gita8aad27.fc31 plymouth-0.9.4-11.20191022git32c097c.fc30
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-03 00:36:55 UTC


Attachments (Terms of Use)

Description Luke Macken 2012-05-25 23:57:46 UTC
As a usability improvement, it would be nice if the plymouth would tell the user that their caps lock key is on while prompting for their encryption passphrase.

Comment 1 gingerling 2014-04-08 14:33:43 UTC
Hi, I don't even have a capslock light working at that stage :/


https://bugzilla.redhat.com/show_bug.cgi?id=1053167

I have hand tremors and its very difficult for me to enter my password with out a capslock symbol or light :S

Comment 2 sedrubal 2016-01-05 01:39:21 UTC
+1

Comment 3 Martin Ueding 2016-05-30 19:16:52 UTC
Especially on the laptop keyboard I accidentally hit the capslock key and mess up all password attempts after that. Any indication (either on screen or with the LED) would be very much appreciated!

Comment 5 Steeve McCauley 2018-12-01 12:29:30 UTC
This is still a problem in Fedora 28.  As I recall, gdm shows an exclamation mark when caps lock is on, an indication of the caps lock state is really needed at this stage of boot.

Comment 6 Martin Ueding 2019-01-02 07:36:16 UTC
I have just tested this on Fedora 29. There is no indicator on screen but the capslock LED on my keyboard lights up as expected. It would be nice if somebody else could test it, but I believe that this is resolved.

Comment 7 Hans de Goede 2019-06-12 07:49:21 UTC
*** Bug 1655221 has been marked as a duplicate of this bug. ***

Comment 8 Jakub Steiner 2019-06-12 13:45:39 UTC
The shell is indicating caps lock in all of the password entries with a dialog-warning-symbolic icon. Similar to caps lock, another common point of failure for invisible entries is having a different input keyboard active than the user expects (probably not applicable here). Many OSes favor allowing to reveal the password/passphrase before commiting the input that solves both of these issues.

See some discussion on the upstream bug here -- https://gitlab.gnome.org/GNOME/gnome-shell/issues/1022

Comment 9 Fedora Update System 2019-10-01 11:57:52 UTC
FEDORA-2019-539bda477c has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-539bda477c

Comment 10 Hans de Goede 2019-10-01 12:54:30 UTC
I've prepared a Fedora update which adds keyboard layout and capslock-state indicator support. This implements the keyboard-status indicator bits from the "Disk Encryption" mockups at the bottom of this image with password-entry mockups:
https://gitlab.gnome.org/Teams/Design/os-mockups/raw/master/password-entry/password-entry.png

Here is a screenshot of what this looks like (with capslock active):
https://fedorapeople.org/~jwrdegoede/flickerfree-videos/keyboard-indicators.png

If you have a chance to test this update and provide karma for it that would be great.

Comment 11 Fedora Update System 2019-10-02 15:53:18 UTC
plymouth-0.9.4-10.20191001gita8aad27.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-539bda477c

Comment 12 Fedora Update System 2019-10-03 00:36:55 UTC
plymouth-0.9.4-10.20191001gita8aad27.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2019-10-23 09:28:50 UTC
FEDORA-2019-40dba3d36e has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-40dba3d36e

Comment 14 Fedora Update System 2019-10-25 19:34:20 UTC
plymouth-0.9.4-11.20191022git32c097c.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-40dba3d36e

Comment 15 Fedora Update System 2019-11-18 01:17:28 UTC
plymouth-0.9.4-11.20191022git32c097c.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.