Bug 825431 - Cannot open display
Cannot open display
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-26 04:49 EDT by Robin Green
Modified: 2012-05-30 15:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-30 15:40:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2012-05-26 04:49:22 EDT
Description of problem:
preupgrade can't start because it can't open the display

Version-Release number of selected component (if applicable):
preupgrade-1.1.10-1.fc16.noarch

How reproducible:
Always

Steps to Reproduce:
1. Start a KDE session
2. Run konsole
3. In konsole, run preupgrade
  
Actual results:
Authentication dialog appears asking for my root password.

Then, in konsole

No protocol specified
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 53, in <module>
    import gtk
  File "/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py", line 64, in <module>
    _init()
  File "/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py", line 52, in _init
    _gtk.init_check()
RuntimeError: could not open display

Expected results:


Additional info:
xterm can start from the same konsole, so there isn't a problem with the DISPLAY variable, which is set to:
:0
Comment 1 Robin Green 2012-05-30 15:40:35 EDT
I can't reproduce this now.

Note You need to log in before you can comment on or make changes to this bug.