Bug 825446 - SELinux is preventing ldconfig from 'append' accesses on the file /var/spool/vscan/var/log/sagator/sagator.log.
SELinux is preventing ldconfig from 'append' accesses on the file /var/spool/...
Status: CLOSED DUPLICATE of bug 825433
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:729df83c86fcae3cda15ff09399...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-26 06:33 EDT by geminic86
Modified: 2012-05-28 02:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-28 02:59:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description geminic86 2012-05-26 06:33:53 EDT
libreport version: 2.0.8
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.6-3.fc16.i686.PAEdebug
reason:         SELinux is preventing ldconfig from 'append' accesses on the file /var/spool/vscan/var/log/sagator/sagator.log.
time:           Sat 26 May 2012 06:59:59 AM EDT

description:
:SELinux is preventing ldconfig from 'append' accesses on the file /var/spool/vscan/var/log/sagator/sagator.log.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that ldconfig should be allowed append access on the sagator.log file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep ldconfig /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:ldconfig_t:s0
:Target Context                system_u:object_r:var_spool_t:s0
:Target Objects                /var/spool/vscan/var/log/sagator/sagator.log [
:                              file ]
:Source                        ldconfig
:Source Path                   ldconfig
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-86.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.6-3.fc16.i686.PAEdebug #1 SMP
:                              Wed May 16 21:57:33 UTC 2012 i686 i686
:Alert Count                   1
:First Seen                    Sat 26 May 2012 05:39:15 AM EDT
:Last Seen                     Sat 26 May 2012 05:39:15 AM EDT
:Local ID                      9a65823d-8f89-4168-ac1c-739be63f92e8
:
:Raw Audit Messages
:type=AVC msg=audit(1338025155.663:392): avc:  denied  { append } for  pid=9296 comm="ldconfig" path="/var/spool/vscan/var/log/sagator/sagator.log" dev="dm-1" ino=917584 scontext=system_u:system_r:ldconfig_t:s0 tcontext=system_u:object_r:var_spool_t:s0 tclass=file
:
:
:Hash: ldconfig,ldconfig_t,var_spool_t,file,append
:
:audit2allow
:
:#============= ldconfig_t ==============
:allow ldconfig_t var_spool_t:file append;
:
:audit2allow -R
:
:#============= ldconfig_t ==============
:allow ldconfig_t var_spool_t:file append;
:
Comment 1 Miroslav Grepl 2012-05-28 02:59:23 EDT

*** This bug has been marked as a duplicate of bug 825433 ***

Note You need to log in before you can comment on or make changes to this bug.