Bug 825467 - systemd fails to start named daemon due to error in PIDFile parameter in /usr/lib/system.d/system/named.service
systemd fails to start named daemon due to error in PIDFile parameter in /usr...
Status: CLOSED DUPLICATE of bug 825466
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-26 12:45 EDT by Sandro Janke
Modified: 2013-04-30 19:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-01 10:53:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sandro Janke 2012-05-26 12:45:56 EDT
Description of problem:

The named daemon fails to start with error message in /var/log/messages:

systemd[1]: PID file /run/named/named.pid not readable (yet?) after start.
systemd[1]: named.service operation timed out. Terminating.

Version-Release number of selected component (if applicable):

bind-9.9.0-4.fc17.x86_64
systemd-44-12.fc17.x86_64

How reproducible:

always

Steps to Reproduce:
1. systemctl start|restart named.service
2.
3.
  
Actual results:

Named cannot be started using systemd. It runs well when started in a console using 'named -fg'.

Expected results:

systemd succeeds starting named

Additional info:

In /usr/lib/systemd/system/named.service (provided by bind package) there is a parameter 'PIDFile' that is set to '/run/named/named.pid'. When changed to '/var/run/named/named.pid' named can be started using systemctl after running 'systemctl --system daemon-reload'.
Comment 1 Adam Tkac 2012-06-01 10:53:22 EDT

*** This bug has been marked as a duplicate of bug 825466 ***

Note You need to log in before you can comment on or make changes to this bug.