Bug 825468 - libktorrent-1.2-0.3rc1.fc17 links to old libgmp version
libktorrent-1.2-0.3rc1.fc17 links to old libgmp version
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libktorrent (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-26 13:23 EDT by Mattia Verga
Modified: 2012-05-29 05:52 EDT (History)
4 users (show)

See Also:
Fixed In Version: libktorrent-1.2.0-2.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-28 20:45:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mattia Verga 2012-05-26 13:23:16 EDT
After upgrading from F16 to F17 KTorrent doesn't start anymore with error:

ktorrent: error while loading shared libraries: libgmp.so.3: cannot open shared object file: No such file or directory

I suspect it should be recompiled for a newer libgmp version (I cannot find libgmp.so.3 anymore):
[lib64]$ ls libgmp*
libgmp.so     libgmp.so.10.0.2  libgmpxx.so.4
libgmp.so.10  libgmpxx.so       libgmpxx.so.4.2.2

I'm using
ktorrent.x86_64                     4.2.0-1.fc17
Comment 1 Rex Dieter 2012-05-26 15:59:01 EDT
rpm -q libktorrent ktorrent

please.

I suspect some botch in our updates system, the latest *should* be

libktorrent-1.2.0-2.fc17.x86_64
ktorrent-4.2.0-1.fc17.x86_64

per,
https://admin.fedoraproject.org/updates/FEDORA-2012-4896/libktorrent-1.2.0-2.fc17

https://admin.fedoraproject.org/updates/FEDORA-2012-3190/ktorrent-4.2.0-1.fc17,libktorrent-1.2.0-1.fc17

But,


$ koji latest-pkg f17 libktorrent ktorrent
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
libktorrent-1.2-0.3rc1.fc17               f17                   ausil
ktorrent-4.2.0-1.fc17                     f17                   nucleo
Comment 2 Rex Dieter 2012-05-26 16:04:30 EDT
Naw, double-checked that both libktorrent pkgs have a dep on 
libgmp.so.10()(64bit)

so, that's not it.

At this point, I'd suggest you try (as root), to ensure your package versions match the latest available:

yum distro-sync
Comment 3 Rex Dieter 2012-05-26 16:06:14 EDT
One more thing,

rpm -q --whatrequires 'libgmp.so.3()(64bit)'

should give us a hint which package is at fault here.
Comment 4 nucleo 2012-05-26 17:08:07 EDT
libktorrent-1.2.0-2.fc17 should be in F17 stable repo but why it is still in updates-testing?
https://admin.fedoraproject.org/updates/FEDORA-2012-4896
Comment 5 Mattia Verga 2012-05-27 04:14:28 EDT
Indeed, I only checked ktorrent and not libktorrent. Seems that libktorrent was not updated to F17:
libktorrent.x86_64                   1.2.0-2.fc16

The problem is the current version in stable repos (1.2.0-2) is greater than the last build (1.2-0.3). I think the last build is wrong, should be 1.2.0-3!

Using 'yum downgrade libktorrent' resolves the issue.
Comment 6 Mattia Verga 2012-05-27 04:24:43 EDT
Forgive me, I was lost in numbers.... libktorrent 1.2.0-2 is actually in F17 updates-testing and with it ktorrent works.
The problem was that I was still using the one in F16 because preupgrade did not updated it.
Comment 7 nucleo 2012-05-28 02:34:45 EDT
libktorrent-1.2.0-2.fc17 pushed to F17 updates.
Comment 8 Rex Dieter 2012-05-28 20:45:06 EDT
confirmed
Comment 9 nucleo 2012-05-29 05:52:23 EDT
libktorrent-1.2-0.3rc1.fc17 links to new version libgmp.so.10
http://koji.fedoraproject.org/koji/rpminfo?rpmID=2978339

libktorrent-1.2.0-2.fc16.x86_64 links to old version libgmp.so.3
http://koji.fedoraproject.org/koji/rpminfo?rpmID=3038546

But when libktorrent-1.2.0-2.fc17 was not in updates libktorrent-1.2.0-2.fc16 was not able to update to libktorrent-1.2-0.3rc1.fc17.

Note You need to log in before you can comment on or make changes to this bug.